Hello Ismael

On 13.10.08 16:31, Ismael Olea wrote:
sx (ssl.c:762) couldn't load certificate from
/etc/pki/tls/private/tormento-jabber-cert.pem; error:0906D06C:PEM
routines:PEM_read_bio:no start line
Mon Oct 13 15:27:35 2008 [error] failed to load olea SSL pemfile

It looks like the .pem file is corrupted, it should be like this:

-----BEGIN CERTIFICATE-----
<many---lines---with---just---7bit---ASCII---at---this---length>
-----END CERTIFICATE-----

I had the problem with missing one of the "-" because of an copy&paste error from the CAcert.org output.

In detail I did the following steps (adjust paths according to your system, this was done on FreeBSD):

$ openssl req -nodes -new -keyout jabber.key -out jabber.csr
        (only enter CN)
    submit jabber.csr to CAcert.org for signing (class3)
    save respond in jabber.pub
$ scp jabber.key jabber.pub [EMAIL PROTECTED]:/usr/local/etc/jabberd/


# cd /usr/local/etc/jabberd
# wget http://www.cacert.org/certs/class3.crt
# wget http://www.cacert.org/certs/root.crt
# cat jabber.pub jabber.key class3.crt root.crt > jabber.pem
# chown root:jabber jabber.pem
# chmod 640 jabber.pem
# openssl x509 -text -in jabber.pem  (to check the cert)
# rm jabber.pub jabber.key class3.crt root.crt
# $EDITOR /usr/local/etc/jabberd/c2s.xml
    adjust path / file name to the .pem in <pemfile> and add
        pemfile='/usr/local/etc/jabberd/jabber.pem'
    to <id password-change='true' and <id register-enable='true'
# /usr/local/etc/rc.d/jabberd restart


Hope this helps.


bye
Fabian

--
To unsubscribe send a mail to [EMAIL PROTECTED]

Reply via email to