2008/10/13 Ismael Olea <[EMAIL PROTECTED]>

>
> sx (ssl.c:762) couldn't load certificate from
> /etc/pki/tls/private/tormento-jabber-cert.pem; error:0906D06C:PEM
> routines:PEM_read_bio:no start line
> Mon Oct 13 15:27:35 2008 [error] failed to load olea SSL pemfile
>
> Can anybody showme the procedure for creating the certificate jabberd needs
> using CACert's ones, please? I've tried several combinations without
> success.
>

ok, I'll answer to myself.

I've a cat of the, using the equivalent apache directive names,
SSLCertificateKeyFile + SSLCertificateFile into a new file and now c2s
initiates as expected.

Now I get another error when trying to connect. I attach the c2s -D log. The
configuration is:

server: jabberd 2.2.4:
c2s.xml:
[...]
<local>
    <id register-enable='false'
        realm="olea.org"
        verify-mode='7'
        require-starttls='yes'
        password-change="false"
        pemfile="/root/peo.peo"
    >olea.org</id>

client: pidgin-2.5.1-1.fc9.i386
~/.purple/accounts.xml
[...]
                <settings>
                        <setting name='require_tls' type='bool'>1</setting>
                        <setting name='ft_proxies' type='string'>
proxy.jabber.org</setting>
                        <setting name='check-mail' type='bool'>0</setting>
                        <setting name='connect_server'
type='string'></setting>
                        <setting name='old_ssl' type='bool'>0</setting>
                        <setting name='auth_plain_in_clear'
type='bool'>0</setting>
                        <setting name='port' type='int'>5222</setting>
                </settings>

I'm using the same client with gtalk using the same SSL configuration
without problem.

Any suggestion?

-- 

Ismael Olea

http://olea.org/diario/

Attachment: c2s.debug.log
Description: Binary data

Reply via email to