Hi Joep (and all), I'm writing a pwm_hardware.jal library, with conditional compile (issue 54: http://code.google.com/p/jallib/issues/detail?id=54). This will provide a far easier API, and I wanted to simplify samples' code.
I plan to disintegrate my manual samples in favor of using board and test files. I have 3 samples for pwm: - 16f88_pwm_led.jal (low resolution pwm, using a LED, freq. constant, duty cycle variable) - 16f88_pwm_led_highres (high resolution pwm, using a LED, freq. constant, duty cycle variable) - 16f88_pwm_sound (duty cycle constant, freq. variable) I understand test_pwm1.jal is quite the same as 16f88_pwm_led.jal. But, since you can do many things with PWM (here: lighting a LED or produce sounds), I'd like to "say" that in the filename. So, can we rename test_pwm1.jal to test_pwm_led.jal ? I'll then add test_pwm_led_highres.jal and test_pwm_sound.jal. About test_pwm2.jal: it uses "only" one channel, the second one (using pwm_ccp2.jal). Could we provide a sample with 2 channels active at the same time, lighting 2 LEDs at different "waves" ? Seb -- Sébastien Lelong http://www.sirloon.net http://sirbot.org --~--~---------~--~----~------------~-------~--~----~ You received this message because you are subscribed to the Google Groups "jallib" group. To post to this group, send email to [email protected] To unsubscribe from this group, send email to [email protected] For more options, visit this group at http://groups.google.com/group/jallib?hl=en -~----------~----~----~----~------~----~------~--~---
