I already use pintools in Jaluino libs... Having both API is better,
particularly if pseudo-arrays consume more resources. Do they ?

Cheers,
Seb

2010/5/12 mattschinkel <[email protected]>

> I can leave the current procedures if you wish and add new ones. You
> have not released this yet so are you worried about API? Are you using
> this in one of your projects?
>
> Matt.
>
> On May 11, 10:54 pm, Sebastien Lelong <[email protected]>
> wrote:
> > Hi Matt,
> >
> > Looks nice. Just to be sure, current API won't be broken, right ?
> >
> > Cheers,
> > Seb
> >
> > 2010/5/12 mattschinkel <[email protected]>
> >
> >
> >
> > > Here's the aliases:
> >
> > > -- alias the pin array to another name
> > > alias pin_direction is pintools_set_direction
> > > alias pin is pintools_set_level
> >
> > > to make it a psudo array, all I had to do is add 'put,
> >
> > > so it is now:
> > > procedure pintools_set_level'put(byte in pinnum, bit in level) is
> >
> > > instead of:
> > > procedure pintools_set_level(byte in pinnum, bit in level) is
> >
> > > but it would be nice to have some 'get procedures. I'll work on it.
> > > With get procedures I can change the sample. Currently you have this:
> >
> > > var bit _led1_level = led1
> > > _led1_level = ! _led1_level
> > > pintools_set_level(0,_led1_level)
> >
> > > but it could be changed to:
> > > pin[0] = !pin[0]
> >
> > > Matt.
> >
> > > On May 11, 8:22 pm, mattschinkel <[email protected]> wrote:
> > > > Actually, I can just put an alias in the sample file:
> >
> > > > alias pin is pin_pintools
> > > > pin[1] = HIGH
> >
> > > > problem solved :)
> >
> > > > Matt.
> >
> > > > On May 11, 7:56 pm, Sunish Issac <[email protected]> wrote:
> >
> > > > > maybe just add pic and make it pic_pin.
> >
> > > > > Sunish
> >
> > > > > On Wed, May 12, 2010 at 3:43 AM, mattschinkel <
> > > [email protected]>wrote:
> >
> > > > > > > "pin" might be a too generic name, may conflict with existing
> code.
> > > > > > Maybe...
> >
> > > > > > What do others think? I would like to have a pseudo array for
> pins:
> >
> > > > > > pin[1] = high
> >
> > > > > > Matt.
> >
> > > > > > --
> > > > > > You received this message because you are subscribed to the
> Google
> > > Groups
> > > > > > "jallib" group.
> > > > > > To post to this group, send email to [email protected].
> > > > > > To unsubscribe from this group, send email to
> > > > > > [email protected]<jallib%[email protected]>
> <jallib%[email protected]<jallib%[email protected]>
> >
> > > <jallib%[email protected]<jallib%[email protected]>
> <jallib%[email protected]<jallib%[email protected]>
> >
> >
> > > > > > .
> > > > > > For more options, visit this group at
> > > > > >http://groups.google.com/group/jallib?hl=en.
> >
> > > > > --
> > > > > You received this message because you are subscribed to the Google
> > > Groups "jallib" group.
> > > > > To post to this group, send email to [email protected].
> > > > > To unsubscribe from this group, send email to
> > > [email protected]<jallib%[email protected]>
> <jallib%[email protected]<jallib%[email protected]>
> >
> > > .
> > > > > For more options, visit this group athttp://
> > > groups.google.com/group/jallib?hl=en.
> >
> > > > --
> > > > You received this message because you are subscribed to the Google
> Groups
> > > "jallib" group.
> > > > To post to this group, send email to [email protected].
> > > > To unsubscribe from this group, send email to
> > > [email protected]<jallib%[email protected]>
> <jallib%[email protected]<jallib%[email protected]>
> >
> > > .
> > > > For more options, visit this group athttp://
> > > groups.google.com/group/jallib?hl=en.
> >
> > > --
> > > You received this message because you are subscribed to the Google
> Groups
> > > "jallib" group.
> > > To post to this group, send email to [email protected].
> > > To unsubscribe from this group, send email to
> > > [email protected]<jallib%[email protected]>
> <jallib%[email protected]<jallib%[email protected]>
> >
> > > .
> > > For more options, visit this group at
> > >http://groups.google.com/group/jallib?hl=en.
> >
> > --
> > Sébastien Lelonghttp://www.sirloon.nethttp://sirbot.org
> >
> > --
> > You received this message because you are subscribed to the Google Groups
> "jallib" group.
> > To post to this group, send email to [email protected].
> > To unsubscribe from this group, send email to
> [email protected]<jallib%[email protected]>
> .
> > For more options, visit this group athttp://
> groups.google.com/group/jallib?hl=en.
>
> --
> You received this message because you are subscribed to the Google Groups
> "jallib" group.
> To post to this group, send email to [email protected].
> To unsubscribe from this group, send email to
> [email protected]<jallib%[email protected]>
> .
> For more options, visit this group at
> http://groups.google.com/group/jallib?hl=en.
>
>


-- 
Sébastien Lelong
http://www.sirloon.net
http://sirbot.org

-- 
You received this message because you are subscribed to the Google Groups 
"jallib" group.
To post to this group, send email to [email protected].
To unsubscribe from this group, send email to 
[email protected].
For more options, visit this group at 
http://groups.google.com/group/jallib?hl=en.

Reply via email to