Dear Kausik.

On 17/10/2016 08:54, Mungo Carstairs (Staff) wrote:
> As a workaround, are you able to edit the jnlp file that is downloaded for 
> Jalview Webstart to increase max-heap-size say to 2G? And run from the 
> command line with javaws.

You can do this automatically with this link:

> 1.       I have 32-bit Java JRE v.1.8.0_101 on my Windows 10 x64 machine.

> 6.       So, I tried: install-jalview.exe LAX_VM “C:\Program Files
(x86)\Java\jre1.8.0_101\bin\java.exe” –i gui
> 7.       The installation went through this time. I was asked to
specify a folder for installation, which I did.
This sounds good...

> 8.       The installation was finished with a note that there were errors.

The installer creates a log containing errors - this should be in the
directory where you unpacked install-jalview.exe

> Now I find that none of the Java .jar executables in the created
Jalview program folder work. None. Double-clicking on them returns no
action at all.

That's not surprising. The install anywhere version creates a
Jalview.exe which you should run to launch the program. If the
installation was successful (which it may not have been) then the
runnable program should have the Jalview logo.

> I cannot use the web-based version, because my FASTA files are large
and I am running out of memory (I tried).

As Mungo suggested - using the webstart + custom memory setting route is
the way forward here. We're working on a smoother way of launching
Jalview with specific memory settings, but for the moment, the launchApp
URL is the easiest way.

Let us know how you get on, Kauskik.

Dr JB Procter, Jalview Coordinator, The Barton Group
Division of Computational Biology, School of Life Sciences
University of Dundee, Dundee DD1 5EH, UK.
+44 1382 388734 | |

Jalview-discuss mailing list

Reply via email to