[ https://issues.apache.org/jira/browse/LUCENE-1614?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12710838#action_12710838 ]
Yonik Seeley commented on LUCENE-1614: -------------------------------------- > > A bigger question though, is if we should support skipTo(doc) where > > doc<=current at all > I don't think we should support it and it wasn't the intention in the first > place. OK... I had read your proposal as saying you wanted skipTo(10) twice in a row to return 10 both times (assuming it matched). Marvin seemed to believe the same thing. > In case you disagree, I'd like to ask why is it bad to request the > implementation to remember its state? I don't disagree, but requiring some implementations to keep and check state would mean less efficient implementations. > To me, calling skipTo or advance with the same target multiple times and get > different result every time is weird. I'd like to change that semantic But I thought we had just agreed that skipTo(doc) is well defined only for doc>current? (see "bigger question" point above). If we all agree that , then we don't need to worry about skipTo(10) being called twice in a row. > Add next() and skipTo() variants to DocIdSetIterator that return the current > doc, instead of boolean > ---------------------------------------------------------------------------------------------------- > > Key: LUCENE-1614 > URL: https://issues.apache.org/jira/browse/LUCENE-1614 > Project: Lucene - Java > Issue Type: Improvement > Components: Search > Reporter: Shai Erera > Fix For: 2.9 > > Attachments: LUCENE-1614.patch > > > See > http://www.nabble.com/Another-possible-optimization---now-in-DocIdSetIterator-p23223319.html > for the full discussion. The basic idea is to add variants to those two > methods that return the current doc they are at, to save successive calls to > doc(). If there are no more docs, return -1. A summary of what was discussed > so far: > # Deprecate those two methods. > # Add nextDoc() and skipToDoc(int) that return doc, with default impl in DISI > (calls next() and skipTo() respectively, and will be changed to abstract in > 3.0). > #* I actually would like to propose an alternative to the names: advance() > and advance(int) - the first advances by one, the second advances to target. > # Wherever these are used, do something like '(doc = advance()) >= 0' instead > of comparing to -1 for improved performance. > I will post a patch shortly -- This message is automatically generated by JIRA. - You can reply to this email to add a comment to the issue online. --------------------------------------------------------------------- To unsubscribe, e-mail: java-dev-unsubscr...@lucene.apache.org For additional commands, e-mail: java-dev-h...@lucene.apache.org