[ https://issues.apache.org/jira/browse/LUCENE-1614?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12710841#action_12710841 ]
Shai Erera commented on LUCENE-1614: ------------------------------------ bq. I wonder if instead of returning -1 when the iteration is done, we should return Integer.MAX_VALUE? The idea was to return a negative value and then compare the returned value to >= 0 for better performance. If we return MAX_VAL we'll need to compare to MAX_VAL, which is less efficient, CPU wise. bq. But I thought we had just agreed that skipTo(doc) is well defined only for doc>current? Not sure - didn't we agree for >= current? An example are two iterators, one over 1, 3, 8, 11 and another on 2, 5, 9, 11. Let's say that you ask both for advance(9). The first one lands on 11 and the second on 9. Then you ask both to advance to 11 again - the first one returns "no more results" and the second one lands on 11. I have to be honest though that I'm not sure to which scenario that matches, I just had a feeling that calling advance(X) while the iterator is on X is something we may run in to and therefore we should make sure to return X. BTW, none of the existing iterators in the code needed to perform any extra check to ensure that behavior. Even TermScorer. bq. I had read your proposal as saying you wanted skipTo(10) twice in a row to return 10 both times (assuming it matched) That's exactly what I meant :) > Add next() and skipTo() variants to DocIdSetIterator that return the current > doc, instead of boolean > ---------------------------------------------------------------------------------------------------- > > Key: LUCENE-1614 > URL: https://issues.apache.org/jira/browse/LUCENE-1614 > Project: Lucene - Java > Issue Type: Improvement > Components: Search > Reporter: Shai Erera > Fix For: 2.9 > > Attachments: LUCENE-1614.patch > > > See > http://www.nabble.com/Another-possible-optimization---now-in-DocIdSetIterator-p23223319.html > for the full discussion. The basic idea is to add variants to those two > methods that return the current doc they are at, to save successive calls to > doc(). If there are no more docs, return -1. A summary of what was discussed > so far: > # Deprecate those two methods. > # Add nextDoc() and skipToDoc(int) that return doc, with default impl in DISI > (calls next() and skipTo() respectively, and will be changed to abstract in > 3.0). > #* I actually would like to propose an alternative to the names: advance() > and advance(int) - the first advances by one, the second advances to target. > # Wherever these are used, do something like '(doc = advance()) >= 0' instead > of comparing to -1 for improved performance. > I will post a patch shortly -- This message is automatically generated by JIRA. - You can reply to this email to add a comment to the issue online. --------------------------------------------------------------------- To unsubscribe, e-mail: java-dev-unsubscr...@lucene.apache.org For additional commands, e-mail: java-dev-h...@lucene.apache.org