[ https://issues.apache.org/jira/browse/LUCENE-1614?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12710384#action_12710384 ]
Yonik Seeley edited comment on LUCENE-1614 at 5/18/09 9:38 AM: --------------------------------------------------------------- An implementation certainly shouldn't be required to carry state such that skipTo(10) called twice will yield different results. A bigger question though, is if we should support skipTo(doc) where doc<=current at all. That's sort of how I read "Skips entries to the first beyond the current"... that you shouldn't be calling skipTo(doc) unless doc>current. If we do want to define skipTo(doc) whendoc<=current, then I agree it should be as you describe. (edited to avoid JIRA markup (n) ) was (Author: ysee...@gmail.com): An implementation certainly shouldn't be required to carry state such that skipTo(10) called twice will yield different results. A bigger question though, is if we should support skipTo(n) where n<=current at all. That's sort of how I read "Skips entries to the first beyond the current"... that you shouldn't be calling skipTo(n) unless n>current. If we do want to define skipTo(n) when n<=current, then I agree it should be as you describe. > Add next() and skipTo() variants to DocIdSetIterator that return the current > doc, instead of boolean > ---------------------------------------------------------------------------------------------------- > > Key: LUCENE-1614 > URL: https://issues.apache.org/jira/browse/LUCENE-1614 > Project: Lucene - Java > Issue Type: Improvement > Components: Search > Reporter: Shai Erera > Fix For: 2.9 > > > See > http://www.nabble.com/Another-possible-optimization---now-in-DocIdSetIterator-p23223319.html > for the full discussion. The basic idea is to add variants to those two > methods that return the current doc they are at, to save successive calls to > doc(). If there are no more docs, return -1. A summary of what was discussed > so far: > # Deprecate those two methods. > # Add nextDoc() and skipToDoc(int) that return doc, with default impl in DISI > (calls next() and skipTo() respectively, and will be changed to abstract in > 3.0). > #* I actually would like to propose an alternative to the names: advance() > and advance(int) - the first advances by one, the second advances to target. > # Wherever these are used, do something like '(doc = advance()) >= 0' instead > of comparing to -1 for improved performance. > I will post a patch shortly -- This message is automatically generated by JIRA. - You can reply to this email to add a comment to the issue online. --------------------------------------------------------------------- To unsubscribe, e-mail: java-dev-unsubscr...@lucene.apache.org For additional commands, e-mail: java-dev-h...@lucene.apache.org