Interesting points, Darren.
I agree that <%beanname.getProperty()%> is potentially
quicker and more readable than the <DISPLAY> syntax
(actually I'm pretty indifferent). However, I'm
unwilling to do away with the <LOOP> tag. Why should I
introduce a new local array index variable just to
enumerate through an array? Also with LOOP, if the
array is an array of beans, you can reference the
current bean and display it's properties without
worrying about the array index. It's a lot cleaner
than scriptlets.
Also, the special JSP tags aren't specifically geared
toward Model 2. They are unrelated to how the JSP is
called.
-Harris
--- Darren Gibbons <[EMAIL PROTECTED]> wrote:
> Hi all,
>
> For what it's worth, I agree with Jason here. I'd
> like to see JSP focus
> more on scriptlets + beans, rather than the approach
> that Model 2 pushes.
> I'd also really like to see his suggestions
> implemented as part of the 1.0
> spec.
>
_________________________________________________________
Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com
===========================================================================
To unsubscribe, send email to [EMAIL PROTECTED] and include in the body
of the message "signoff JSP-INTEREST". For general help, send email to
[EMAIL PROTECTED] and include in the body of the message "help".