kexec
Thread
Date
Earlier messages
Messages by Thread
[PATCH v7 0/7] Support kdump with LUKS encryption by reusing LUKS volume keys
Coiby Xu
[PATCH v7 1/7] kexec_file: allow to place kexec_buf randomly
Coiby Xu
[PATCH v7 2/7] crash_dump: make dm crypt keys persist for the kdump kernel
Coiby Xu
Re: [PATCH v7 2/7] crash_dump: make dm crypt keys persist for the kdump kernel
Randy Dunlap
Re: [PATCH v7 2/7] crash_dump: make dm crypt keys persist for the kdump kernel
Coiby Xu
[PATCH v7 3/7] crash_dump: store dm crypt keys in kdump reserved memory
Coiby Xu
[PATCH v7 4/7] crash_dump: reuse saved dm crypt keys for CPU/memory hot-plugging
Coiby Xu
[PATCH v7 5/7] crash_dump: retrieve dm crypt keys in kdump kernel
Coiby Xu
[PATCH v7 6/7] x86/crash: pass dm crypt keys to kdump kernel
Coiby Xu
[PATCH v7 7/7] x86/crash: make the page that stores the dm crypt keys inaccessible
Coiby Xu
[PATCH v6 0/7] x86/kexec: Add exception handling for relocate_kernel
David Woodhouse
[PATCH v6 5/7] x86/kexec: Add 8250 serial port output
David Woodhouse
[PATCH v6 1/7] x86/kexec: Add CONFIG_KEXEC_DEBUG option
David Woodhouse
[PATCH v6 4/7] x86/kexec: Debugging support: Dump registers on exception
David Woodhouse
[PATCH v6 6/7] x86/kexec: Add 8250 MMIO serial port output
David Woodhouse
[PATCH v6 2/7] x86/kexec: Debugging support: load a GDT
David Woodhouse
[PATCH v6 7/7] [DO NOT MERGE] x86/kexec: Add int3 in kexec path for testing
David Woodhouse
[PATCH v6 3/7] x86/kexec: Debugging support: Load an IDT and basic exception entry points
David Woodhouse
[PATCH v5 0/6] elf: Define note name macros
Akihiko Odaki
[PATCH v5 1/6] elf: Define note name macros
Akihiko Odaki
Re: [PATCH v5 1/6] elf: Define note name macros
Dave Martin
[PATCH v5 3/6] powerpc: Use note name macros
Akihiko Odaki
[PATCH v5 4/6] crash: Use note name macros
Akihiko Odaki
[PATCH v5 5/6] s390/crash: Use note name macros
Akihiko Odaki
[PATCH v5 2/6] binfmt_elf: Use note name macros
Akihiko Odaki
[PATCH v5 6/6] crash: Remove KEXEC_CORE_NOTE_NAME
Akihiko Odaki
[RFC] kexec: Use bpf to allow kexec to load PE format boot image
Pingfan Liu
[REGRESSION] Kernel booted via kexec fails to resume from hibernation
Roberto Ricci
Re: [REGRESSION] Kernel booted via kexec fails to resume from hibernation
Roberto Ricci
Re: [REGRESSION] Kernel booted via kexec fails to resume from hibernation
Baoquan He
Re: [REGRESSION] Kernel booted via kexec fails to resume from hibernation
Andrew Morton
Re: [REGRESSION] Kernel booted via kexec fails to resume from hibernation
Roberto Ricci
Re: [REGRESSION] Kernel booted via kexec fails to resume from hibernation
Roberto Ricci
Re: [REGRESSION] Kernel booted via kexec fails to resume from hibernation
Baoquan He
Re: [REGRESSION] Kernel booted via kexec fails to resume from hibernation
Roberto Ricci
Re: [REGRESSION] Kernel booted via kexec fails to resume from hibernation
Roberto Ricci
Re: [REGRESSION] Kernel booted via kexec fails to resume from hibernation
Baoquan He
Re: [REGRESSION] Kernel booted via kexec fails to resume from hibernation
Baoquan He
Re: [REGRESSION] Kernel booted via kexec fails to resume from hibernation
Yuntao Wang
[Feedback Needed] Hypervisor live update biweekly meeting time
David Rientjes
[PATCH v4 0/6] elf: Define note name macros
Akihiko Odaki
[PATCH v4 1/6] elf: Define note name macros
Akihiko Odaki
Re: [PATCH v4 1/6] elf: Define note name macros
Dave Martin
[PATCH v4 2/6] binfmt_elf: Use note name macros
Akihiko Odaki
Re: [PATCH v4 2/6] binfmt_elf: Use note name macros
Dave Martin
[PATCH v4 3/6] powerpc: Use note name macros
Akihiko Odaki
Re: [PATCH v4 3/6] powerpc: Use note name macros
Dave Martin
[PATCH v4 5/6] s390/crash: Use note name macros
Akihiko Odaki
Re: [PATCH v4 5/6] s390/crash: Use note name macros
Dave Martin
[PATCH v4 6/6] crash: Remove KEXEC_CORE_NOTE_NAME
Akihiko Odaki
Re: [PATCH v4 6/6] crash: Remove KEXEC_CORE_NOTE_NAME
Dave Martin
[PATCH v4 4/6] crash: Use note name macros
Akihiko Odaki
Re: [PATCH v4 4/6] crash: Use note name macros
Dave Martin
[PATCH v2] treewide: const qualify ctl_tables where applicable
Joel Granados
Re: [PATCH v2] treewide: const qualify ctl_tables where applicable
Anna Schumaker
Re: [PATCH v2] treewide: const qualify ctl_tables where applicable
Baoquan He
[PATCH] fs/proc: fix softlockup in __read_vmcore (part 2)
Rik van Riel
[PATCH] Resending patch: Improve message readability and fix typos
Seiji Nishikawa
[PATCH] Improve message readability and fix typos
Seiji Nishikawa
[PATCH] treewide: const qualify ctl_tables where applicable
Joel Granados
Re: [PATCH] treewide: const qualify ctl_tables where applicable
Steven Rostedt
Re: [PATCH] treewide: const qualify ctl_tables where applicable
Jani Nikula
Re: [PATCH] treewide: const qualify ctl_tables where applicable
Martin K. Petersen
Re: [PATCH] treewide: const qualify ctl_tables where applicable
Corey Minyard
Re: [PATCH] treewide: const qualify ctl_tables where applicable
Darrick J. Wong
Re: [PATCH] treewide: const qualify ctl_tables where applicable
Song Liu
Re: [PATCH] treewide: const qualify ctl_tables where applicable
Dixit, Ashutosh
[PATCH v2 0/9] x86/kexec: Fixes for tip/x86/boot
David Woodhouse
[PATCH v2 8/9] x86/kexec: Cope with relocate_kernel() not being at the start of the page
David Woodhouse
[PATCH v2 2/9] x86/kexec: Ensure preserve_context flag is set on return to kernel
David Woodhouse
[PATCH v2 1/9] x86/kexec: Disable global pages before writing to control page
David Woodhouse
[PATCH v2 3/9] x86/kexec: Use correct swap page in swap_pages function
David Woodhouse
[PATCH v2 7/9] kexec_core: Add and update comments regarding the KEXEC_JUMP flow
David Woodhouse
[PATCH v2 9/9] x86/kexec: Use typedef for relocate_kernel_fn function prototype
David Woodhouse
[PATCH v2 6/9] x86/kexec: Mark machine_kexec() with __nocfi
David Woodhouse
[PATCH v2 5/9] x86/kexec: Fix location of relocate_kernel with -ffunction-sections
David Woodhouse
[PATCH v2 4/9] x86/kexec: Fix stack and handling of re-entry point for ::preserve_context
David Woodhouse
Re: [PATCH v2 0/9] x86/kexec: Fixes for tip/x86/boot
David Woodhouse
Re: [PATCH v2 0/9] x86/kexec: Fixes for tip/x86/boot
Borislav Petkov
Re: [PATCH v2 0/9] x86/kexec: Fixes for tip/x86/boot
David Woodhouse
Re: [PATCH v2 0/9] x86/kexec: Fixes for tip/x86/boot
Borislav Petkov
[PATCH] Improve message readability and fix typos
Seiji Nishikawa
[RFC 0/2] efi/memattr: Fix memory corruption and warning issues
Usama Arif
[RFC 2/2] efi/memattr: add efi_mem_attr_table as a reserved region in 820_table_firmware
Usama Arif
Re: [RFC 2/2] efi/memattr: add efi_mem_attr_table as a reserved region in 820_table_firmware
Ard Biesheuvel
Re: [RFC 2/2] efi/memattr: add efi_mem_attr_table as a reserved region in 820_table_firmware
Usama Arif
Re: [RFC 2/2] efi/memattr: add efi_mem_attr_table as a reserved region in 820_table_firmware
Gregory Price
Re: [RFC 2/2] efi/memattr: add efi_mem_attr_table as a reserved region in 820_table_firmware
Ard Biesheuvel
Re: [RFC 2/2] efi/memattr: add efi_mem_attr_table as a reserved region in 820_table_firmware
Breno Leitao
Re: [RFC 2/2] efi/memattr: add efi_mem_attr_table as a reserved region in 820_table_firmware
Ard Biesheuvel
Re: [RFC 2/2] efi/memattr: add efi_mem_attr_table as a reserved region in 820_table_firmware
Usama Arif
Re: [RFC 2/2] efi/memattr: add efi_mem_attr_table as a reserved region in 820_table_firmware
Usama Arif
Re: [RFC 2/2] efi/memattr: add efi_mem_attr_table as a reserved region in 820_table_firmware
Dave Young
Re: [RFC 2/2] efi/memattr: add efi_mem_attr_table as a reserved region in 820_table_firmware
Usama Arif
Re: [RFC 2/2] efi/memattr: add efi_mem_attr_table as a reserved region in 820_table_firmware
Dave Young
Re: [RFC 2/2] efi/memattr: add efi_mem_attr_table as a reserved region in 820_table_firmware
Dave Young
Re: [RFC 2/2] efi/memattr: add efi_mem_attr_table as a reserved region in 820_table_firmware
Usama Arif
[RFC 1/2] efi/memattr: Use desc_size instead of total size to check for corruption
Usama Arif
Re: [RFC 1/2] efi/memattr: Use desc_size instead of total size to check for corruption
Ard Biesheuvel
Re: [RFC 1/2] efi/memattr: Use desc_size instead of total size to check for corruption
Usama Arif
Re: [RFC 1/2] efi/memattr: Use desc_size instead of total size to check for corruption
Ard Biesheuvel
Re: [RFC 1/2] efi/memattr: Use desc_size instead of total size to check for corruption
Usama Arif
Re: [RFC 1/2] efi/memattr: Use desc_size instead of total size to check for corruption
Ard Biesheuvel
Re: [RFC 1/2] efi/memattr: Use desc_size instead of total size to check for corruption
Dave Young
Re: [RFC 1/2] efi/memattr: Use desc_size instead of total size to check for corruption
Usama Arif
Re: [RFC 1/2] efi/memattr: Use desc_size instead of total size to check for corruption
Usama Arif
[PATCH RESEND v1 0/5] powerpc/crash: use generic crashkernel reservation
Sourabh Jain
[PATCH RESEND v1 1/5] crash: remove an unused argument from reserve_crashkernel_generic()
Sourabh Jain
Re: [PATCH RESEND v1 1/5] crash: remove an unused argument from reserve_crashkernel_generic()
Baoquan he
Re: [PATCH RESEND v1 1/5] crash: remove an unused argument from reserve_crashkernel_generic()
Sourabh Jain
[PATCH RESEND v1 2/5] crash: let arch decide crash memory export to iomem_resource
Sourabh Jain
Re: [PATCH RESEND v1 2/5] crash: let arch decide crash memory export to iomem_resource
Baoquan he
Re: [PATCH RESEND v1 2/5] crash: let arch decide crash memory export to iomem_resource
Sourabh Jain
[PATCH RESEND v1 3/5] powerpc/kdump: preserve user-specified memory limit
Sourabh Jain
Re: [PATCH RESEND v1 3/5] powerpc/kdump: preserve user-specified memory limit
Mahesh J Salgaonkar
Re: [PATCH RESEND v1 3/5] powerpc/kdump: preserve user-specified memory limit
Sourabh Jain
[PATCH RESEND v1 4/5] powerpc/crash: use generic crashkernel reservation
Sourabh Jain
Re: [PATCH RESEND v1 4/5] powerpc/crash: use generic crashkernel reservation
Mahesh J Salgaonkar
Re: [PATCH RESEND v1 4/5] powerpc/crash: use generic crashkernel reservation
Sourabh Jain
[PATCH RESEND v1 5/5] crash: option to let arch decide mem range is usable
Sourabh Jain
Re: [PATCH RESEND v1 5/5] crash: option to let arch decide mem range is usable
Baoquan he
Re: [PATCH RESEND v1 5/5] crash: option to let arch decide mem range is usable
Sourabh Jain
[PATCH v3 0/6] elf: Define note name macros
Akihiko Odaki
[PATCH v3 3/6] powwerpc: Use note name macros
Akihiko Odaki
Re: [PATCH v3 3/6] powwerpc: Use note name macros
LEROY Christophe
[PATCH v3 2/6] binfmt_elf: Use note name macros
Akihiko Odaki
Re: [PATCH v3 2/6] binfmt_elf: Use note name macros
Dave Martin
Re: [PATCH v3 2/6] binfmt_elf: Use note name macros
Akihiko Odaki
Re: [PATCH v3 2/6] binfmt_elf: Use note name macros
Dave Martin
[PATCH v3 5/6] s390/crash: Use note name macros
Akihiko Odaki
Re: [PATCH v3 5/6] s390/crash: Use note name macros
Dave Martin
Re: [PATCH v3 5/6] s390/crash: Use note name macros
Akihiko Odaki
Re: [PATCH v3 5/6] s390/crash: Use note name macros
Heiko Carstens
Re: [PATCH v3 5/6] s390/crash: Use note name macros
Dave Martin
Re: [PATCH v3 5/6] s390/crash: Use note name macros
Akihiko Odaki
Re: [PATCH v3 5/6] s390/crash: Use note name macros
Dave Martin
[PATCH v3 1/6] elf: Define note name macros
Akihiko Odaki
[PATCH v3 4/6] crash: Use note name macros
Akihiko Odaki
[PATCH v3 6/6] crash: Remove KEXEC_CORE_NOTE_NAME
Akihiko Odaki
[PATCH v12 00/19] x86: Trenchboot secure dynamic launch Linux kernel support
Ross Philipson
[PATCH v12 06/19] x86: Add early SHA-256 support for Secure Launch early measurements
Ross Philipson
[PATCH v12 07/19] x86/msr: Add variable MTRR base/mask and x2apic ID registers
Ross Philipson
[PATCH v12 15/19] tpm, tpm_tis: Address positive localities in tpm_tis_request_locality()
Ross Philipson
[PATCH v12 12/19] kexec: Secure Launch kexec SEXIT support
Ross Philipson
[PATCH v12 13/19] x86/reboot: Secure Launch SEXIT support on reboot paths
Ross Philipson
[PATCH v12 08/19] x86/boot: Place TXT MLE header in the kernel_info section
Ross Philipson
[PATCH v12 10/19] x86: Secure Launch kernel late boot stub
Ross Philipson
[PATCH v12 19/19] x86/efi: EFI stub DRTM launch support for Secure Launch
Ross Philipson
[PATCH v12 11/19] x86: Secure Launch SMP bringup support
Ross Philipson
[PATCH v12 14/19] tpm, tpm_tis: Close all localities
Ross Philipson
[PATCH v12 18/19] x86: Secure Launch late initcall platform module
Ross Philipson
[PATCH v12 05/19] x86: Add early SHA-1 support for Secure Launch early measurements
Ross Philipson
[PATCH v12 16/19] tpm, tpm_tis: Allow locality to be set to a different value
Ross Philipson
[PATCH v12 03/19] x86: Secure Launch Resource Table header file
Ross Philipson
[PATCH v12 02/19] x86: Secure Launch Kconfig
Ross Philipson
[PATCH v12 17/19] tpm, sysfs: Show locality used by kernel
Ross Philipson
[PATCH v12 04/19] x86: Secure Launch main header file
Ross Philipson
[PATCH v12 09/19] x86: Secure Launch kernel early boot stub
Ross Philipson
[PATCH v12 01/19] Documentation/x86: Secure Launch kernel documentation
Ross Philipson
[PATCH v2] crash: Export PAGE_UNACCEPTED_MAPCOUNT_VALUE to vmcoreinfo
Zhiquan Li
[PATCH v2 0/5] elf: Define note name macros
Akihiko Odaki
[PATCH v2 1/5] elf: Define note name macros
Akihiko Odaki
Re: [PATCH v2 1/5] elf: Define note name macros
Baoquan He
Re: [PATCH v2 1/5] elf: Define note name macros
Akihiko Odaki
Re: [PATCH v2 1/5] elf: Define note name macros
Baoquan He
Re: [PATCH v2 1/5] elf: Define note name macros
Dave Martin
Re: [PATCH v2 1/5] elf: Define note name macros
Kees Cook
Re: [PATCH v2 1/5] elf: Define note name macros
Dave Martin
[PATCH v2 4/5] crash: Use note name macros
Akihiko Odaki
[PATCH v2 3/5] powwerpc: Use note name macros
Akihiko Odaki
[PATCH v2 2/5] binfmt_elf: Use note name macros
Akihiko Odaki
[PATCH v2 5/5] crash: Remove KEXEC_CORE_NOTE_NAME
Akihiko Odaki
Re: [PATCH v2 5/5] crash: Remove KEXEC_CORE_NOTE_NAME
Dave Martin
Re: [PATCH v2 0/5] elf: Define note name macros
Baoquan He
Re: [PATCH v2 0/5] elf: Define note name macros
Dave Martin
[PATCH] crash: Export PAGE_UNACCEPTED_MAPCOUNT_VALUE to vmcoreinfo
Zhiquan Li
Re: [PATCH] crash: Export PAGE_UNACCEPTED_MAPCOUNT_VALUE to vmcoreinfo
Dave Young
Re: [PATCH] crash: Export PAGE_UNACCEPTED_MAPCOUNT_VALUE to vmcoreinfo
Zhiquan Li
Re: [PATCH] crash: Export PAGE_UNACCEPTED_MAPCOUNT_VALUE to vmcoreinfo
Kirill A. Shutemov
Re: Unified Kernel Image Support
Yishen Miao
[PATCH 0/5] powerpc/crash: use generic crashkernel reservation
Sourabh Jain
[PATCH 2/5] crash: let arch decide crash memory export to iomem_resource
Sourabh Jain
[PATCH 1/5] crash: remove an unused argument from reserve_crashkernel_generic()
Sourabh Jain
[PATCH 4/5] powerpc/crash: use generic crashkernel reservation
Sourabh Jain
[PATCH 3/5] powerpc/kdump: preserve user-specified memory limit
Sourabh Jain
[PATCH 5/5] crash: option to let arch decide mem range is usable
Sourabh Jain
[PATCH 0/9] x86/kexec: Fixes for tip/x86/boot
David Woodhouse
[PATCH 6/9] x86/kexec: Mark machine_kexec() with __nocfi
David Woodhouse
[PATCH 8/9] x86/kexec: Cope with relocate_kernel() not being at the start of the page
David Woodhouse
Re: [PATCH 8/9] x86/kexec: Cope with relocate_kernel() not being at the start of the page
Ard Biesheuvel
Re: [PATCH 8/9] x86/kexec: Cope with relocate_kernel() not being at the start of the page
David Woodhouse
Re: [PATCH 8/9] x86/kexec: Cope with relocate_kernel() not being at the start of the page
Ard Biesheuvel
Re: [PATCH 8/9] x86/kexec: Cope with relocate_kernel() not being at the start of the page
David Woodhouse
Re: [PATCH 8/9] x86/kexec: Cope with relocate_kernel() not being at the start of the page
David Woodhouse
Re: [PATCH 8/9] x86/kexec: Cope with relocate_kernel() not being at the start of the page
Ard Biesheuvel
Re: [PATCH 8/9] x86/kexec: Cope with relocate_kernel() not being at the start of the page
David Woodhouse
Re: [PATCH 8/9] x86/kexec: Cope with relocate_kernel() not being at the start of the page
Ard Biesheuvel
[PATCH 2/9] x86/kexec: Ensure preserve_context flag is set on return to kernel
David Woodhouse
Re: [PATCH 2/9] x86/kexec: Ensure preserve_context flag is set on return to kernel
Uros Bizjak
Re: [PATCH 2/9] x86/kexec: Ensure preserve_context flag is set on return to kernel
David Woodhouse
Earlier messages