On 27/09/15 22:22, Vittorio Giovara wrote:
> On Sun, Sep 27, 2015 at 2:41 AM, Vittorio Giovara
> <[email protected]> wrote:
>> This field was used in combination with coded_frame to compute some
>> sort of PSNR value. Regardless of its use, this property is tied to the
>> encoding processing, while AVFrame is a structure suited for decoded
>> data only.
>>
>> The only use of this field (besides the deprecated coded_frame) is
>> in mpegvideoenc: since it might be used in bframes estimation, add an
>> additional field to Picture, which is a private structure anyway.
>>
>> Signed-off-by: Vittorio Giovara <[email protected]>
>> ---
>> Improved names for the new variable are welcome.
>> Vittorio
> 
> It was decided on IRC to use a less verbose and more direct commit log
> 
> "These field are difficult to interpret, and are provided by a single
> encoder (mpegvideoenc). In general they do not belong to a stucture
> containing raw data only, so remove them from avframe.
> 
> Mpegvideoenc now uses a private field in Picture for its internal 
> computations."
> 
> I feel that this new field name could be something more descriptive
> than "error", but I am not really sure which one to pick:
> compression_error, divergence, plane_factor? Does anybody have any
> preference?
> 

divergence

And the message is ok for me as long you fix the typos.

lu
_______________________________________________
libav-devel mailing list
[email protected]
https://lists.libav.org/mailman/listinfo/libav-devel

Reply via email to