On 12/08/17 19:45, Diego Biurrun wrote:
> On Sat, Aug 12, 2017 at 07:23:50PM +0100, Mark Thompson wrote:
>> On 12/08/17 09:44, Diego Biurrun wrote:
>>> On Fri, Aug 11, 2017 at 12:36:57AM +0100, Mark Thompson wrote:
>>>> --- /dev/null
>>>> +++ b/libavcodec/cbs_h2645.c
>>>> @@ -0,0 +1,997 @@
>>>> +
>>>> +#define FUNC(name) FUNC_H264(READWRITE, name)
>>>> +#include "cbs_h264_syntax.c"
>>>> +#undef FUNC
>>>> +
>>>> +#define FUNC(name) FUNC_H264(READWRITE, name)
>>>> +#include "cbs_h264_syntax.c"
>>>> +#undef FUNC
>>> The convention is for these files to be called *_template.c.
>> Given that I'm making a load of these files and they have pretty 
>> clearly-defined contents, can I create a new convention?
> Well, they really are template files - what's the problem, the name
> gets too long for your taste? cbs_h264_template.c would work as well,
> unless you also have cbs_h264_something_else.c in the queue.

Yeah, mainly thinking it's uglier than without _template.

> I do believe that naming conventions do help organize things sensibly,
> so I'm reluctant to let this go to be honest...

Ok, changed (to cbs_foo_syntax_template.c).

New version reflecting all review comments is going through oracle now.  
(Excepting adding spaces to pointer casts, which other people have argued 
against and I don't think was ever agreed to be a thing to do generally.)

Assuming oracle doesn't find any more problems (no more anonymous unions or 
anything) and there are no more comments then I'll push 1-12 (11 split into 
two) later tomorrow.  13/14 are waiting for testing on Windows, and I'll post 
MPEG-2 support as a new set at some point in future.


- Mark
libav-devel mailing list

Reply via email to