On Apr 30, 2010, at 1:44 PM, Roy Stogner wrote: > Okay, I misunderstood what we were talking about then. This is just > fine - it effectively *is* what I was calling a "functor" approach, > despite it not being a plain "overload operator()". I thought you > were talking about requiring users to overload NonlinearSystem.
Ah - gotcha. Nope... not that. But I'm not sure this new object is necessary at all. I believe that Ben had talked about doing this before... possibly making all the callbacks look like this... > Fair enough. I'll leave the decision up to Ben; he's the first person > I thought of who would be affected. K - glad my stubbornness is overriding your good judgement! ;-) Derek ------------------------------------------------------------------------------ _______________________________________________ Libmesh-devel mailing list [email protected] https://lists.sourceforge.net/lists/listinfo/libmesh-devel
