Luca Fascione

On Wed, 26 Aug 2026, 18:42 David Kastrup, <[email protected]> wrote:

>
>
> In this case it would be a fairly full base class (there are quite few
> members particular to only book or bookpart).  I have no idea whether
> that would make a difference regarding the undesirability.
>


I would call it "base" if it made not much sense to use it that level of
the class hierarchy: it seems to me in this context you'd have book objects
and bookpart objects flowing around, and that you'd love to be able to say
"I just need to tell book-ish things apart from... other stuff" but you'd
never want to make a book_base object per-se. This would be the criterion
I'd use to select this naming pattern.

L

>

Reply via email to