LGTM

On Wed, Feb 28, 2018 at 11:28 AM, Bart Van Assche
<[email protected]> wrote:
> Use the blk_queue_flag_{set,clear}() functions instead of open-coding
> these.
>
> Signed-off-by: Bart Van Assche <[email protected]>
> Cc: Michael Lyle <[email protected]>
> Cc: Kent Overstreet <[email protected]>
> Cc: Christoph Hellwig <[email protected]>
> Cc: Hannes Reinecke <[email protected]>
> Cc: Johannes Thumshirn <[email protected]>
> Cc: Ming Lei <[email protected]>
> ---
>  drivers/md/bcache/super.c | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/md/bcache/super.c b/drivers/md/bcache/super.c
> index 312895788036..047e30cb93dc 100644
> --- a/drivers/md/bcache/super.c
> +++ b/drivers/md/bcache/super.c
> @@ -833,9 +833,9 @@ static int bcache_device_init(struct bcache_device *d, 
> unsigned block_size,
>         q->limits.io_min                = block_size;
>         q->limits.logical_block_size    = block_size;
>         q->limits.physical_block_size   = block_size;
> -       set_bit(QUEUE_FLAG_NONROT,      &d->disk->queue->queue_flags);
> -       clear_bit(QUEUE_FLAG_ADD_RANDOM, &d->disk->queue->queue_flags);
> -       set_bit(QUEUE_FLAG_DISCARD,     &d->disk->queue->queue_flags);
> +       blk_queue_flag_set(QUEUE_FLAG_NONROT, d->disk->queue);
> +       blk_queue_flag_clear(QUEUE_FLAG_ADD_RANDOM, d->disk->queue);
> +       blk_queue_flag_set(QUEUE_FLAG_DISCARD, d->disk->queue);
>
>         blk_queue_write_cache(q, true, true);
>
> --
> 2.16.2
>

Reply via email to