* Juergen Gross <jgr...@suse.com> wrote:

> So what about the following:
> 
> From version 0x020e on (current version without my patches is 0x020d)
> the boot loader will write its supported version or'ed with 0x8000 into
> the same version field. So we can be sure any added fields are filled
> with real data or the information has been evaluated by the boot loader,
> if the returned version included that field. If the boot loader finds
> the kernel supports a version < 0x020e it won't return its supported
> version.

This seems like a usable workaround to me, as long as everyone involved
agrees with it.

I've removed the patches for the time being.

Thanks,

        Ingo

Reply via email to