linux-trace-kernel
Thread
Date
Earlier messages
Messages by Thread
[syzbot] [block?] [trace?] KASAN: slab-out-of-bounds Read in seq_buf_putmem
syzbot
[PATCH 0/6] userfaultfd: decouple uffd mode from VMA flags
Mike Rapoport (Microsoft)
[PATCH 3/6] userfaultfd: use userfaultfd_*() helpers instead of open coded flag tests
Mike Rapoport (Microsoft)
Re: [PATCH 3/6] userfaultfd: use userfaultfd_*() helpers instead of open coded flag tests
Barry Song
[PATCH 6/6] userfaultfd: collapse VM_UFFD_{MISSING,WP,MINOR,RWP} into single VM_UFFD
Mike Rapoport (Microsoft)
[PATCH 4/6] userfaultfd: rename vm_userfaultfd_ctx to vm_uffd_state
Mike Rapoport (Microsoft)
[PATCH 5/6] userfaultfd: decouple fault reason from VMA flags
Mike Rapoport (Microsoft)
[PATCH 2/6] userfaultfd: constify VMA parameter of userfaultfd_*() helpers
Mike Rapoport (Microsoft)
Re: [PATCH 2/6] userfaultfd: constify VMA parameter of userfaultfd_*() helpers
sashiko-bot
Re: [PATCH 2/6] userfaultfd: constify VMA parameter of userfaultfd_*() helpers
Barry Song
[PATCH 1/6] mm/gup: move gup_can_follow_protnone() to gup.c
Mike Rapoport (Microsoft)
Re: [PATCH 1/6] mm/gup: move gup_can_follow_protnone() to gup.c
Barry Song
[PATCH v2] fork: initialize function graph state before copy_exec_state()
Jérémy Jean
Re: [PATCH v3] fork: initialize function graph state before copy_exec_state()
Bradley Morgan
Re: [PATCH v3] fork: initialize function graph state before copy_exec_state()
Steven Rostedt
Re: [PATCH v3] fork: initialize function graph state before copy_exec_state()
Jérémy Jean
Re: [PATCH v3] fork: initialize function graph state before copy_exec_state()
Steven Rostedt
Re: [PATCH v3] fork: initialize function graph state before copy_exec_state()
Jérémy Jean
Re: [PATCH v3] fork: initialize function graph state before copy_exec_state()
Bradley Morgan
Re: [PATCH v3] fork: initialize function graph state before copy_exec_state()
Steven Rostedt
[RFC PATCH 0/9] arm64: Allocate .text and .init.text together
Ard Biesheuvel
[RFC PATCH 6/9] arm64: Enable the execmem ROX cache for module text
Ard Biesheuvel
Re: [RFC PATCH 6/9] arm64: Enable the execmem ROX cache for module text
sashiko-bot
Re: [RFC PATCH 6/9] arm64: Enable the execmem ROX cache for module text
Adrian Barnaś
[RFC PATCH 1/9] mm: execmem: Add API to split an existing execmem cache allocation
Ard Biesheuvel
[RFC PATCH 2/9] mm: execmem: Allow huge vmappings to be avoided for execmem caches
Ard Biesheuvel
Re: [RFC PATCH 2/9] mm: execmem: Allow huge vmappings to be avoided for execmem caches
sashiko-bot
[RFC PATCH 4/9] module: Allocate MOD_INIT_TEXT from the MOD_TEXT ROX allocation
Ard Biesheuvel
[RFC PATCH 3/9] module: Place MOD_TEXT before MOD_INIT_TEXT in enumeration
Ard Biesheuvel
Re: [RFC PATCH 3/9] module: Place MOD_TEXT before MOD_INIT_TEXT in enumeration
sashiko-bot
[RFC PATCH 8/9] arm64: module: Combine init and core PLT entries again
Ard Biesheuvel
Re: [RFC PATCH 8/9] arm64: module: Combine init and core PLT entries again
sashiko-bot
[RFC PATCH 7/9] arm64: ftrace: Revert "fix unreachable PLT for ftrace_caller ..."
Ard Biesheuvel
[RFC PATCH 5/9] arm64: mm: Permit permissions changes on huge vmappings
Ard Biesheuvel
Re: [RFC PATCH 5/9] arm64: mm: Permit permissions changes on huge vmappings
sashiko-bot
Re: [RFC PATCH 5/9] arm64: mm: Permit permissions changes on huge vmappings
Adrian Barnaś
[RFC PATCH 9/9] arm64: ftrace: Simplify PLT handling
Ard Biesheuvel
[PATCH v13 00/12] tracing: wprobe: x86: Add wprobe for watchpoint
Masami Hiramatsu (Google)
[PATCH v13 01/12] kprobes: Protect kprobe_blacklist with RCU
Masami Hiramatsu (Google)
Re: [PATCH v13 01/12] kprobes: Protect kprobe_blacklist with RCU
sashiko-bot
[PATCH v13 02/12] x86/hw_breakpoints: Make DR7 updates NMI safe
Masami Hiramatsu (Google)
Re: [PATCH v13 02/12] x86/hw_breakpoints: Make DR7 updates NMI safe
sashiko-bot
[PATCH v13 03/12] x86/hw_breakpoints: Add arch_modify_local_hw_breakpoint_addr() API
Masami Hiramatsu (Google)
Re: [PATCH v13 03/12] x86/hw_breakpoints: Add arch_modify_local_hw_breakpoint_addr() API
sashiko-bot
[PATCH v13 04/12] HWBP: Add modify_local_hw_breakpoint_addr() API
Masami Hiramatsu (Google)
Re: [PATCH v13 04/12] HWBP: Add modify_local_hw_breakpoint_addr() API
sashiko-bot
[PATCH v13 06/12] x86: hw_breakpoint: Add a kconfig to clarify when a breakpoint fires
Masami Hiramatsu (Google)
Re: [PATCH v13 06/12] x86: hw_breakpoint: Add a kconfig to clarify when a breakpoint fires
sashiko-bot
[PATCH v13 08/12] selftests: tracing: Add syntax testcase for wprobe
Masami Hiramatsu (Google)
Re: [PATCH v13 08/12] selftests: tracing: Add syntax testcase for wprobe
sashiko-bot
[PATCH v13 05/12] tracing/wprobe: Add wprobe (watchpoint probe) trace event support
Masami Hiramatsu (Google)
Re: [PATCH v13 05/12] tracing/wprobe: Add wprobe (watchpoint probe) trace event support
sashiko-bot
[PATCH v13 11/12] tracing/wprobe: Support BTF typecast in fetchargs
Masami Hiramatsu (Google)
Re: [PATCH v13 11/12] tracing/wprobe: Support BTF typecast in fetchargs
sashiko-bot
[PATCH v13 07/12] selftests: tracing: Add a basic testcase for wprobe
Masami Hiramatsu (Google)
Re: [PATCH v13 07/12] selftests: tracing: Add a basic testcase for wprobe
sashiko-bot
[PATCH v13 12/12] tracing/wprobe: Support BTF struct offset resolution in set_wprobe trigger
Masami Hiramatsu (Google)
Re: [PATCH v13 12/12] tracing/wprobe: Support BTF struct offset resolution in set_wprobe trigger
sashiko-bot
[PATCH v13 09/12] tracing/wprobe: Add set_wprobe and clear_wprobe event triggers
Masami Hiramatsu (Google)
Re: [PATCH v13 09/12] tracing/wprobe: Add set_wprobe and clear_wprobe event triggers
sashiko-bot
[PATCH v13 10/12] selftests: ftrace: Add wprobe trigger testcase
Masami Hiramatsu (Google)
Re: [PATCH v13 10/12] selftests: ftrace: Add wprobe trigger testcase
sashiko-bot
[PATCH] uprobes: Free utask on dup_return_instance() failure
Keke Ming
Re: [PATCH] uprobes: Free utask on dup_return_instance() failure
sashiko-bot
Re: [PATCH] uprobes: Free utask on dup_return_instance() failure
Google
Re: [PATCH] uprobes: Free utask on dup_return_instance() failure
Keke Ming
[PATCH v2] uprobes: Free utask on dup_return_instance() failure
Keke Ming
Re: [PATCH v2] uprobes: Free utask on dup_return_instance() failure
sashiko-bot
Re: [PATCH] uprobes: Free utask on dup_return_instance() failure
Oleg Nesterov
Re: [PATCH] uprobes: Free utask on dup_return_instance() failure
Keke Ming
Re: [PATCH] uprobes: Free utask on dup_return_instance() failure
Oleg Nesterov
[PATCH v2 0/2] tracing: Add 'within' filter logic
Steven Rostedt
[PATCH v2 2/2] tracnig: Add proper error message for glob use with "within" filter
Steven Rostedt
[PATCH v2 1/2] tracing: Add "within" filter for call-stack-based event filtering
Steven Rostedt
[RFC PATCH v2 00/24] unwind_user: Implement .eh_frame handling
Jens Remus
[RFC PATCH v2 17/24] unwind_user/eh_frame: Add support for DWARF expressions
Jens Remus
Re: [RFC PATCH v2 17/24] unwind_user/eh_frame: Add support for DWARF expressions
sashiko-bot
[RFC PATCH v2 03/24] unwind_user: Enable archs that pass RA in a register
Jens Remus
Re: [RFC PATCH v2 03/24] unwind_user: Enable archs that pass RA in a register
sashiko-bot
[RFC PATCH v2 01/24] unwind_user: Add generic and arch-specific headers to MAINTAINERS
Jens Remus
[RFC PATCH v2 13/24] unwind_user/eh_frame: Show file name in debug output
Jens Remus
Re: [RFC PATCH v2 13/24] unwind_user/eh_frame: Show file name in debug output
sashiko-bot
[RFC PATCH v2 10/24] unwind_user/eh_frame: Detect .eh_frame_hdr sections in executables
Jens Remus
Re: [RFC PATCH v2 10/24] unwind_user/eh_frame: Detect .eh_frame_hdr sections in executables
sashiko-bot
[RFC PATCH v2 22/24] s390/ptrace: Provide frame_pointer()
Jens Remus
Re: [RFC PATCH v2 22/24] s390/ptrace: Provide frame_pointer()
sashiko-bot
[RFC PATCH v2 04/24] unwind_user: Flexible FP/RA recovery rules
Jens Remus
Re: [RFC PATCH v2 04/24] unwind_user: Flexible FP/RA recovery rules
sashiko-bot
[RFC PATCH v2 11/24] unwind_user/eh_frame: Wire up unwind_user to eh_frame
Jens Remus
Re: [RFC PATCH v2 11/24] unwind_user/eh_frame: Wire up unwind_user to eh_frame
sashiko-bot
[RFC PATCH v2 08/24] unwind_user/eh_frame: Store .eh_frame_hdr section data in per-mm maple tree
Jens Remus
Re: [RFC PATCH v2 08/24] unwind_user/eh_frame: Store .eh_frame_hdr section data in per-mm maple tree
sashiko-bot
[RFC PATCH v2 02/24] unwind_user: Stop when reaching an outermost frame
Jens Remus
Re: [RFC PATCH v2 02/24] unwind_user: Stop when reaching an outermost frame
sashiko-bot
[RFC PATCH v2 18/24] x86/uaccess: Add unsafe_copy_from_user() implementation
Jens Remus
Re: [RFC PATCH v2 18/24] x86/uaccess: Add unsafe_copy_from_user() implementation
sashiko-bot
[RFC PATCH v2 21/24] unwind_user/eh_frame/x86: Handle DRAP expressions
Jens Remus
Re: [RFC PATCH v2 21/24] unwind_user/eh_frame/x86: Handle DRAP expressions
sashiko-bot
[RFC PATCH v2 19/24] unwind_user/eh_frame/x86: Enable eh_frame unwinding on x86
Jens Remus
Re: [RFC PATCH v2 19/24] unwind_user/eh_frame/x86: Enable eh_frame unwinding on x86
sashiko-bot
[RFC PATCH v2 07/24] unwind_user/eh_frame: Add support for reading .eh_frame_hdr section
Jens Remus
Re: [RFC PATCH v2 07/24] unwind_user/eh_frame: Add support for reading .eh_frame_hdr section
sashiko-bot
[RFC PATCH v2 16/24] unwind_user/eh_frame: Ignore DW_CFA_GNU_args_size
Jens Remus
Re: [RFC PATCH v2 16/24] unwind_user/eh_frame: Ignore DW_CFA_GNU_args_size
sashiko-bot
[RFC PATCH v2 14/24] unwind_user/eh_frame: Add .eh_frame[_hdr] validation option
Jens Remus
Re: [RFC PATCH v2 14/24] unwind_user/eh_frame: Add .eh_frame[_hdr] validation option
sashiko-bot
[RFC PATCH v2 20/24] unwind_user/eh_frame/x86: Handle PLT expressions
Jens Remus
Re: [RFC PATCH v2 20/24] unwind_user/eh_frame/x86: Handle PLT expressions
sashiko-bot
[RFC PATCH v2 24/24] unwind_user/eh_frame: Add prctl() interface for (un)registering .eh_frame_hdr sections
Jens Remus
Re: [RFC PATCH v2 24/24] unwind_user/eh_frame: Add prctl() interface for (un)registering .eh_frame_hdr sections
sashiko-bot
[RFC PATCH v2 23/24] unwind_user/eh_frame/s390: Enable eh_frame unwinding on s390
Jens Remus
Re: [RFC PATCH v2 23/24] unwind_user/eh_frame/s390: Enable eh_frame unwinding on s390
sashiko-bot
[RFC PATCH v2 12/24] unwind_user/eh_frame: Remove .eh_frame[_hdr] section on detected corruption
Jens Remus
Re: [RFC PATCH v2 12/24] unwind_user/eh_frame: Remove .eh_frame[_hdr] section on detected corruption
sashiko-bot
[RFC PATCH v2 06/24] unwind_user: Enable archs that define CFA = SP_callsite + offset
Jens Remus
Re: [RFC PATCH v2 06/24] unwind_user: Enable archs that define CFA = SP_callsite + offset
sashiko-bot
[RFC PATCH v2 15/24] unwind_user/eh_frame: Duplicate registered .eh_frame[_hdr] section data on clone/fork
Jens Remus
Re: [RFC PATCH v2 15/24] unwind_user/eh_frame: Duplicate registered .eh_frame[_hdr] section data on clone/fork
sashiko-bot
[RFC PATCH v2 09/24] unwind_user/eh_frame: Add support for reading .eh_frame section
Jens Remus
Re: [RFC PATCH v2 09/24] unwind_user/eh_frame: Add support for reading .eh_frame section
sashiko-bot
[RFC PATCH v2 05/24] unwind_user: Flexible CFA recovery rules
Jens Remus
Re: [RFC PATCH v2 05/24] unwind_user: Flexible CFA recovery rules
sashiko-bot
[PATCH] perf/bpf: Fix lockless access to parent_event->prog in perf_event_alloc()
Deepanshu Kartikey
Re: [PATCH] perf/bpf: Fix lockless access to parent_event->prog in perf_event_alloc()
sashiko-bot
Re: [PATCH] perf/bpf: Fix lockless access to parent_event->prog in perf_event_alloc()
bot+bpf-ci
Re: [PATCH] perf/bpf: Fix lockless access to parent_event->prog in perf_event_alloc()
Andrii Nakryiko
[PATCH v6 0/9] rv: Add task latency over budget RV monitor
wen . yang
[PATCH v6 2/9] rv: Add generic uprobe infrastructure for RV monitors
wen . yang
Re: [PATCH v6 2/9] rv: Add generic uprobe infrastructure for RV monitors
sashiko-bot
[PATCH v6 3/9] rv: Add tlob model DOT file
wen . yang
Re: [PATCH v6 3/9] rv: Add tlob model DOT file
sashiko-bot
[PATCH v6 5/9] rv: Make da_monitor_reset_hook and EVENT_NONE_LBL overridable
wen . yang
Re: [PATCH v6 5/9] rv: Make da_monitor_reset_hook and EVENT_NONE_LBL overridable
sashiko-bot
[PATCH v6 8/9] selftests/verification: Add tlob selftests
wen . yang
Re: [PATCH v6 8/9] selftests/verification: Add tlob selftests
sashiko-bot
[PATCH v6 1/9] rv: Introduce DA_MON_ALLOCATION_STRATEGY
wen . yang
[PATCH v6 9/9] selftests/ftrace: Walk up to find test.d/functions when a subdirectory is passed
wen . yang
Re: [PATCH v6 9/9] selftests/ftrace: Walk up to find test.d/functions when a subdirectory is passed
sashiko-bot
[PATCH v6 4/9] rv: Fix ha_invariant_passed_ns silent bypass of invariant check
wen . yang
Re: [PATCH v6 4/9] rv: Fix ha_invariant_passed_ns silent bypass of invariant check
sashiko-bot
[PATCH v6 6/9] rv: Add tlob hybrid automaton monitor
wen . yang
Re: [PATCH v6 6/9] rv: Add tlob hybrid automaton monitor
sashiko-bot
[PATCH v6 7/9] rv: Add KUnit tests for the tlob monitor
wen . yang
[PATCH v4 0/7] ntfs3: add tracepoints for core filesystem paths
Baolin Liu
[PATCH v4 5/7] ntfs3: add allocation tracepoints
Baolin Liu
[PATCH v4 4/7] ntfs3: add directory index tracepoints
Baolin Liu
Re: [PATCH v4 4/7] ntfs3: add directory index tracepoints
sashiko-bot
[PATCH v4 1/7] ntfs3: add mount and log replay tracepoints
Baolin Liu
[PATCH v4 7/7] ntfs3: add file I/O tracepoints
Baolin Liu
Re: [PATCH v4 7/7] ntfs3: add file I/O tracepoints
sashiko-bot
[PATCH v4 3/7] ntfs3: add create inode tracepoint
Baolin Liu
[PATCH v4 6/7] ntfs3: add iomap tracepoints
Baolin Liu
Re: [PATCH v4 6/7] ntfs3: add iomap tracepoints
sashiko-bot
[PATCH v4 2/7] ntfs3: add namei tracepoints
Baolin Liu
[PATCH v5 0/9] rv: Add task latency over budget RV monitor
wen . yang
[PATCH v5 2/9] rv: Add generic uprobe infrastructure for RV monitors
wen . yang
Re: [PATCH v5 2/9] rv: Add generic uprobe infrastructure for RV monitors
sashiko-bot
[PATCH v5 1/9] rv: Introduce DA_MON_ALLOCATION_STRATEGY
wen . yang
Re: [PATCH v5 1/9] rv: Introduce DA_MON_ALLOCATION_STRATEGY
sashiko-bot
[PATCH v5 3/9] rv: Add tlob model DOT file
wen . yang
Re: [PATCH v5 3/9] rv: Add tlob model DOT file
sashiko-bot
[PATCH v5 9/9] selftests/ftrace: Walk up to find test.d/functions when a subdirectory is passed
wen . yang
Re: [PATCH v5 9/9] selftests/ftrace: Walk up to find test.d/functions when a subdirectory is passed
sashiko-bot
[PATCH v5 6/9] rv: Add tlob hybrid automaton monitor
wen . yang
Re: [PATCH v5 6/9] rv: Add tlob hybrid automaton monitor
sashiko-bot
[PATCH v5 8/9] selftests/verification: Add tlob selftests
wen . yang
Re: [PATCH v5 8/9] selftests/verification: Add tlob selftests
sashiko-bot
[PATCH v5 4/9] rv: Fix ha_invariant_passed_ns silent bypass of invariant check
wen . yang
Re: [PATCH v5 4/9] rv: Fix ha_invariant_passed_ns silent bypass of invariant check
sashiko-bot
[PATCH v5 5/9] rv: Make da_monitor_reset_hook and EVENT_NONE_LBL overridable
wen . yang
Re: [PATCH v5 5/9] rv: Make da_monitor_reset_hook and EVENT_NONE_LBL overridable
sashiko-bot
[PATCH v5 7/9] rv: Add KUnit tests for the tlob monitor
wen . yang
Re: [PATCH v5 7/9] rv: Add KUnit tests for the tlob monitor
sashiko-bot
[RFC PATCH v1 00/25] unwind_user: Implement .eh_frame handling
Jens Remus
[RFC PATCH v1 13/25] unwind_user/eh_frame: Show file name in debug output
Jens Remus
Re: [RFC PATCH v1 13/25] unwind_user/eh_frame: Show file name in debug output
sashiko-bot
[RFC PATCH v1 19/25] x86/uaccess: Add unsafe_copy_from_user() implementation
Jens Remus
Re: [RFC PATCH v1 19/25] x86/uaccess: Add unsafe_copy_from_user() implementation
sashiko-bot
[RFC PATCH v1 05/25] unwind_user: Flexible CFA recovery rules
Jens Remus
Re: [RFC PATCH v1 05/25] unwind_user: Flexible CFA recovery rules
sashiko-bot
[RFC PATCH v1 03/25] unwind_user: Enable archs that pass RA in a register
Jens Remus
Re: [RFC PATCH v1 03/25] unwind_user: Enable archs that pass RA in a register
sashiko-bot
[RFC PATCH v1 18/25] unwind_user/eh_frame: Add support for DWARF expressions
Jens Remus
Re: [RFC PATCH v1 18/25] unwind_user/eh_frame: Add support for DWARF expressions
sashiko-bot
Re: [RFC PATCH v1 18/25] unwind_user/eh_frame: Add support for DWARF expressions
Jens Remus
[RFC PATCH v1 04/25] unwind_user: Flexible FP/RA recovery rules
Jens Remus
Re: [RFC PATCH v1 04/25] unwind_user: Flexible FP/RA recovery rules
sashiko-bot
[RFC PATCH v1 25/25] unwind_user/eh_frame: Add prctl() interface for (un)registering .eh_frame_hdr sections
Jens Remus
Re: [RFC PATCH v1 25/25] unwind_user/eh_frame: Add prctl() interface for (un)registering .eh_frame_hdr sections
sashiko-bot
Re: [RFC PATCH v1 25/25] unwind_user/eh_frame: Add prctl() interface for (un)registering .eh_frame_hdr sections
Jens Remus
[RFC PATCH v1 24/25] unwind_user/eh_frame/s390: Enable eh_frame unwinding on s390
Jens Remus
Re: [RFC PATCH v1 24/25] unwind_user/eh_frame/s390: Enable eh_frame unwinding on s390
sashiko-bot
[RFC PATCH v1 15/25] unwind_user/eh_frame: Duplicate registered .eh_frame[_hdr] section data on clone/fork
Jens Remus
Re: [RFC PATCH v1 15/25] unwind_user/eh_frame: Duplicate registered .eh_frame[_hdr] section data on clone/fork
sashiko-bot
Re: [RFC PATCH v1 15/25] unwind_user/eh_frame: Duplicate registered .eh_frame[_hdr] section data on clone/fork
Jens Remus
[RFC PATCH v1 01/25] unwind_user: Add generic and arch-specific headers to MAINTAINERS
Jens Remus
[RFC PATCH v1 23/25] s390/ptrace: Provide frame_pointer()
Jens Remus
Re: [RFC PATCH v1 23/25] s390/ptrace: Provide frame_pointer()
sashiko-bot
[RFC PATCH v1 02/25] unwind_user: Stop when reaching an outermost frame
Jens Remus
Re: [RFC PATCH v1 02/25] unwind_user: Stop when reaching an outermost frame
sashiko-bot
Earlier messages