linux-trace-kernel
Thread
Date
Earlier messages
Later messages
Messages by Thread
Re: [PATCH v2 5/8] kernel: convert process/thread iterators to for_each_*_rculock
Lorenzo Stoakes (ARM)
Re: [PATCH v2 5/8] kernel: convert process/thread iterators to for_each_*_rculock
Gregory Price
Re: [PATCH v2 5/8] kernel: convert process/thread iterators to for_each_*_rculock
Oleg Nesterov
Re: [PATCH v2 5/8] kernel: convert process/thread iterators to for_each_*_rculock
Gregory Price
Re: [PATCH v2 5/8] kernel: convert process/thread iterators to for_each_*_rculock
Oleg Nesterov
Re: [PATCH v2 5/8] kernel: convert process/thread iterators to for_each_*_rculock
Gregory Price
Re: [PATCH v2 5/8] kernel: convert process/thread iterators to for_each_*_rculock
Oleg Nesterov
Re: [PATCH v2 5/8] kernel: convert process/thread iterators to for_each_*_rculock
K Prateek Nayak
Re: [PATCH v2 5/8] kernel: convert process/thread iterators to for_each_*_rculock
Oleg Nesterov
Re: [PATCH v2 5/8] kernel: convert process/thread iterators to for_each_*_rculock
Gregory Price
Re: [PATCH v2 5/8] kernel: convert process/thread iterators to for_each_*_rculock
Peter Zijlstra
Re: [PATCH v2 5/8] kernel: convert process/thread iterators to for_each_*_rculock
SJ Park
Re: [PATCH v2 5/8] kernel: convert process/thread iterators to for_each_*_rculock
Oleg Nesterov
Re: [PATCH v2 5/8] kernel: convert process/thread iterators to for_each_*_rculock
Peter Zijlstra
Re: [PATCH v2 5/8] kernel: convert process/thread iterators to for_each_*_rculock
Steven Rostedt
Re: [PATCH v2 5/8] kernel: convert process/thread iterators to for_each_*_rculock
Peter Zijlstra
[PATCH v2 6/8] fs: convert process/thread iterators to for_each_*_rculock
Ye Liu
Re: [PATCH v2 6/8] fs: convert process/thread iterators to for_each_*_rculock
sashiko-bot
Re: [PATCH v2 6/8] fs: convert process/thread iterators to for_each_*_rculock
Gregory Price
Re: [PATCH v2 6/8] fs: convert process/thread iterators to for_each_*_rculock
Lorenzo Stoakes (ARM)
Re: [PATCH v2 6/8] fs: convert process/thread iterators to for_each_*_rculock
SJ Park
[PATCH v2 2/8] mm/oom_kill: convert process/thread iterators to for_each_*_rculock
Ye Liu
Re: [PATCH v2 2/8] mm/oom_kill: convert process/thread iterators to for_each_*_rculock
Lorenzo Stoakes (ARM)
Re: [PATCH v2 2/8] mm/oom_kill: convert process/thread iterators to for_each_*_rculock
Gregory Price
[PATCH v2 4/8] mm/memory-failure: convert process iterator to for_each_process_rculock
Ye Liu
Re: [PATCH v2 4/8] mm/memory-failure: convert process iterator to for_each_process_rculock
Lorenzo Stoakes (ARM)
Re: [PATCH v2 4/8] mm/memory-failure: convert process iterator to for_each_process_rculock
Gregory Price
Re: [PATCH v2 4/8] mm/memory-failure: convert process iterator to for_each_process_rculock
SJ Park
[PATCH v2 8/8] security/landlock: convert thread iterator to for_each_thread_rculock
Ye Liu
Re: [PATCH v2 8/8] security/landlock: convert thread iterator to for_each_thread_rculock
Lorenzo Stoakes (ARM)
Re: [PATCH v2 8/8] security/landlock: convert thread iterator to for_each_thread_rculock
Gregory Price
Re: [PATCH v2 8/8] security/landlock: convert thread iterator to for_each_thread_rculock
SJ Park
[PATCH v2 7/8] lib: convert process iterator to for_each_process_rculock
Ye Liu
Re: [PATCH v2 7/8] lib: convert process iterator to for_each_process_rculock
Lorenzo Stoakes (ARM)
Re: [PATCH v2 7/8] lib: convert process iterator to for_each_process_rculock
Gregory Price
Re: [PATCH v2 7/8] lib: convert process iterator to for_each_process_rculock
SJ Park
Re: [PATCH v2 0/8] sched: introduce for_each_process_rculock and for_each_thread_rculock
Lorenzo Stoakes (ARM)
[PATCH v2 3/8] mm/ksm: convert process iterator to for_each_process_rculock
Ye Liu
Re: [PATCH v2 3/8] mm/ksm: convert process iterator to for_each_process_rculock
Lorenzo Stoakes (ARM)
Re: [PATCH v2 3/8] mm/ksm: convert process iterator to for_each_process_rculock
Gregory Price
Re: [PATCH v2 3/8] mm/ksm: convert process iterator to for_each_process_rculock
David Hildenbrand (Arm)
[PATCH 08/14] tracing: fix typo "preceeded" in comment
Hemanth Selam
[PATCH] tracing: fix typo "availabe" in comment
Hemanth Selam
[PATCH] tracing: hist: keep the entry count when the stats allocation fails
Donggeun Yoo
Re: [PATCH] tracing: hist: keep the entry count when the stats allocation fails
Google
Re: [PATCH] tracing: hist: keep the entry count when the stats allocation fails
Steven Rostedt
[PATCH] tracing: hist: let values keep the percent and graph modifiers
Donggeun Yoo
Re: [PATCH] tracing: hist: let values keep the percent and graph modifiers
sashiko-bot
Re: [PATCH] tracing: hist: let values keep the percent and graph modifiers
Donggeun Yoo
[PATCH RFC 0/2] mm/mglru: add tracepoints for aging and isolation
Ridong Chen
[PATCH RFC 2/2] mm/mglru: add tracepoint for inc_max_seq
Ridong Chen
Re: [PATCH RFC 2/2] mm/mglru: add tracepoint for inc_max_seq
Barry Song
Re: [PATCH RFC 2/2] mm/mglru: add tracepoint for inc_max_seq
Ridong Chen
[PATCH RFC 1/2] mm/mglru: add tracepoint for folio isolation
Ridong Chen
Re: [PATCH RFC 1/2] mm/mglru: add tracepoint for folio isolation
Barry Song
Re: [PATCH RFC 1/2] mm/mglru: add tracepoint for folio isolation
Ridong Chen
Re: [PATCH RFC 1/2] mm/mglru: add tracepoint for folio isolation
Barry Song
Re: [PATCH RFC 1/2] mm/mglru: add tracepoint for folio isolation
Ridong Chen
Re: [PATCH RFC 0/2] mm/mglru: add tracepoints for aging and isolation
Ridong Chen
[PATCH] tracing: hist: free the field rejected for a bad modifier
Donggeun Yoo
Re: [PATCH] tracing: hist: free the field rejected for a bad modifier
sashiko-bot
Re: [PATCH] tracing: hist: free the field rejected for a bad modifier
Donggeun Yoo
[PATCH v15 00/12] tracing: wprobe: x86: Add wprobe for watchpoint
Masami Hiramatsu (Google)
[PATCH v15 03/12] x86/hw_breakpoints: Add arch_modify_local_hw_breakpoint_addr() API
Masami Hiramatsu (Google)
Re: [PATCH v15 03/12] x86/hw_breakpoints: Add arch_modify_local_hw_breakpoint_addr() API
sashiko-bot
[PATCH v15 01/12] x86/mce: Fix hardware debug register corruption on task migration
Masami Hiramatsu (Google)
Re: [PATCH v15 01/12] x86/mce: Fix hardware debug register corruption on task migration
sashiko-bot
[PATCH v15 05/12] tracing/wprobe: Add wprobe (watchpoint probe) trace event support
Masami Hiramatsu (Google)
Re: [PATCH v15 05/12] tracing/wprobe: Add wprobe (watchpoint probe) trace event support
sashiko-bot
[PATCH v15 02/12] x86/hw_breakpoints: Make DR7 updates NMI safe
Masami Hiramatsu (Google)
Re: [PATCH v15 02/12] x86/hw_breakpoints: Make DR7 updates NMI safe
sashiko-bot
[PATCH v15 06/12] x86: hw_breakpoint: Add a kconfig to clarify when a breakpoint fires
Masami Hiramatsu (Google)
Re: [PATCH v15 06/12] x86: hw_breakpoint: Add a kconfig to clarify when a breakpoint fires
sashiko-bot
[PATCH v15 04/12] HWBP: Add modify_local_hw_breakpoint_addr() API
Masami Hiramatsu (Google)
Re: [PATCH v15 04/12] HWBP: Add modify_local_hw_breakpoint_addr() API
sashiko-bot
[PATCH v15 08/12] selftests: tracing: Add syntax testcase for wprobe
Masami Hiramatsu (Google)
Re: [PATCH v15 08/12] selftests: tracing: Add syntax testcase for wprobe
sashiko-bot
[PATCH v15 07/12] selftests: tracing: Add a basic testcase for wprobe
Masami Hiramatsu (Google)
Re: [PATCH v15 07/12] selftests: tracing: Add a basic testcase for wprobe
sashiko-bot
[PATCH v15 12/12] tracing/wprobe: Support BTF struct offset resolution in set_wprobe trigger
Masami Hiramatsu (Google)
Re: [PATCH v15 12/12] tracing/wprobe: Support BTF struct offset resolution in set_wprobe trigger
sashiko-bot
[PATCH v15 09/12] tracing/wprobe: Add set_wprobe and clear_wprobe event triggers
Masami Hiramatsu (Google)
Re: [PATCH v15 09/12] tracing/wprobe: Add set_wprobe and clear_wprobe event triggers
sashiko-bot
[PATCH v15 10/12] selftests: tracing: Add wprobe trigger testcase
Masami Hiramatsu (Google)
Re: [PATCH v15 10/12] selftests: tracing: Add wprobe trigger testcase
sashiko-bot
[PATCH v15 11/12] tracing/wprobe: Support BTF typecast in fetchargs
Masami Hiramatsu (Google)
Re: [PATCH v15 11/12] tracing/wprobe: Support BTF typecast in fetchargs
sashiko-bot
[syzbot] [trace?] WARNING in ring_buffer_map_get_reader (3)
syzbot
Re: [syzbot] [trace?] WARNING in ring_buffer_map_get_reader (3)
syzbot
[PATCH v5 0/5] rv/reactors: fix lockdep warning and add tests
wen . yang
[PATCH v5 1/5] rv/reactors: use LD_WAIT_SPIN as the reactor lockdep wait type
wen . yang
Re: [PATCH v5 1/5] rv/reactors: use LD_WAIT_SPIN as the reactor lockdep wait type
sashiko-bot
[PATCH v5 2/5] rv/reactors: propagate rv_register_reactor() error from reactor init
wen . yang
[PATCH v5 3/5] rv/reactors: export rv_register_reactor() and rv_unregister_reactor()
wen . yang
[PATCH v5 4/5] rv/reactors: add KUnit tests for reactor registration and dispatch
wen . yang
Re: [PATCH v5 4/5] rv/reactors: add KUnit tests for reactor registration and dispatch
sashiko-bot
[PATCH v5 5/5] selftests/verification: Test loadable module-based reactor
wen . yang
Re: [PATCH v5 5/5] selftests/verification: Test loadable module-based reactor
sashiko-bot
[PATCH] tracing: hist: free var refs regardless of how often they are referenced
Donggeun Yoo
Re: [PATCH] tracing: hist: free var refs regardless of how often they are referenced
sashiko-bot
Re: [PATCH] tracing: hist: free var refs regardless of how often they are referenced
Donggeun Yoo
[PATCH] tracing: hist: free the var ref when its initialization fails
Donggeun Yoo
Re: [PATCH] tracing: hist: free the var ref when its initialization fails
sashiko-bot
Re: [PATCH] tracing: hist: free the var ref when its initialization fails
Donggeun Yoo
Re: [PATCH] tracing: hist: free the var ref when its initialization fails
Donggeun Yoo
[PATCH] function_graph: Use the saved entry's size when reprinting it
Donggeun Yoo
Re: [PATCH] function_graph: Use the saved entry's size when reprinting it
sashiko-bot
Re: [PATCH] function_graph: Use the saved entry's size when reprinting it
Donggeun Yoo
[PATCH] fgraph: Remove unused FGRAPH_MAX_INDEX
Donggeun Yoo
Re: [PATCH] fgraph: Remove unused FGRAPH_MAX_INDEX
Google
[PATCH] bootconfig: remove unreachable index checks in xbc_verify_tree()
Sang-Heon Jeon
Re: [PATCH] bootconfig: remove unreachable index checks in xbc_verify_tree()
Google
Re: [PATCH] bootconfig: remove unreachable index checks in xbc_verify_tree()
Sang-Heon Jeon
Re: [PATCH] bootconfig: remove unreachable index checks in xbc_verify_tree()
Google
Re: [PATCH] bootconfig: remove unreachable index checks in xbc_verify_tree()
Sang-Heon Jeon
[PATCH 0/2] tracing: add ring-buffer memory usage statistics
Xiang Gao
[PATCH 1/2] tracing: add ring-buffer memory usage statistics in tracefs
Xiang Gao
Re: [PATCH 1/2] tracing: add ring-buffer memory usage statistics in tracefs
sashiko-bot
Re: [PATCH 1/2] tracing: add ring-buffer memory usage statistics in tracefs
Vincent Donnefort
[PATCH 2/2] tracing: add per-CPU memory usage statistics in tracefs
Xiang Gao
[PATCH v3 0/4] dmaengine: rename dma_chan::dev to dma_chan::chan_dev for clarity
Frank . Li
[PATCH v3 1/4] dmaengine: vchan: add vchan_chan_name() to get channel device name
Frank . Li
Re: [PATCH v3 1/4] dmaengine: vchan: add vchan_chan_name() to get channel device name
sashiko-bot
Re: [PATCH v3 1/4] dmaengine: vchan: add vchan_chan_name() to get channel device name
Amelie Delaunay
[PATCH v3 2/4] dmaengine: use dma_chan_name() helper to get per-channel device name
Frank . Li
Re: [PATCH v3 2/4] dmaengine: use dma_chan_name() helper to get per-channel device name
sashiko-bot
Re: [PATCH v3 2/4] dmaengine: use dma_chan_name() helper to get per-channel device name
Andy Shevchenko
Re: [PATCH v3 2/4] dmaengine: use dma_chan_name() helper to get per-channel device name
Amelie Delaunay
[PATCH v3 4/4] dmaengine: add union chan_dev for dma_chan::dev for clarity
Frank . Li
Re: [PATCH v3 4/4] dmaengine: add union chan_dev for dma_chan::dev for clarity
sashiko-bot
Re: [PATCH v3 4/4] dmaengine: add union chan_dev for dma_chan::dev for clarity
Andy Shevchenko
Re: [PATCH v3 3/4] dmaengine: add (dmaengine|vchan)_chan_dev() helper
sashiko-bot
Re: [PATCH v3 0/4] dmaengine: rename dma_chan::dev to dma_chan::chan_dev for clarity
Andy Shevchenko
Re: [PATCH v3 3/4] dmaengine: add (dmaengine|vchan)_chan_dev() helper
Amelie Delaunay
Re: [PATCH v3 3/4] dmaengine: add (dmaengine|vchan)_chan_dev() helper
Vinod Koul
[PATCH] ring-buffer: Use a macro for static buffer bits
Steven Rostedt
Re: [PATCH] ring-buffer: Use a macro for static buffer bits
Vincent Donnefort
[PATCH] tracing: Fix comment in tracing_buffers_splice_read()
Steven Rostedt
Re: [PATCH] tracing: Fix comment in tracing_buffers_splice_read()
Vincent Donnefort
[PATCH v2 0/3] Add telemetry tracepoints for CPU hogs, distress, and BH budget yields
Aaron Tomlin
[PATCH v2 1/3] workqueue: Add workqueue_cpu_intensive tracepoint
Aaron Tomlin
[PATCH v2 2/3] workqueue: Add workqueue_mayday and workqueue_rescued tracepoints
Aaron Tomlin
[PATCH v2 3/3] workqueue: Add workqueue_bh_budget_yield tracepoint
Aaron Tomlin
Re: [PATCH v2 0/3] Add telemetry tracepoints for CPU hogs, distress, and BH budget yields
Tejun Heo
Re: [PATCH v2 0/3] Add telemetry tracepoints for CPU hogs, distress, and BH budget yields
Aaron Tomlin
[PATCH v10 0/4] ring-buffer: Fixes for subbuf resizing and persistent buffers
Vincent Donnefort
[PATCH v10 4/4] ring-buffer: Prevent truncation of nr_pages / nr_subbufs
Vincent Donnefort
Re: [PATCH v10 4/4] ring-buffer: Prevent truncation of nr_pages / nr_subbufs
sashiko-bot
[PATCH v10 1/4] ring-buffer: Allow splice reads on static buffers
Vincent Donnefort
Re: [PATCH v10 1/4] ring-buffer: Allow splice reads on static buffers
sashiko-bot
Re: [PATCH v10 1/4] ring-buffer: Allow splice reads on static buffers
Steven Rostedt
[PATCH v10 3/4] ring-buffer: Cap static ring buffer nr_pages
Vincent Donnefort
Re: [PATCH v10 3/4] ring-buffer: Cap static ring buffer nr_pages
sashiko-bot
[PATCH v10 2/4] tracing: Fix subbuf resize races with trace_pipe_raw readers
Vincent Donnefort
Re: [PATCH v10 2/4] tracing: Fix subbuf resize races with trace_pipe_raw readers
Steven Rostedt
Re: [PATCH v10 2/4] tracing: Fix subbuf resize races with trace_pipe_raw readers
Steven Rostedt
Re: [PATCH v10 0/4] ring-buffer: Fixes for subbuf resizing and persistent buffers
Steven Rostedt
Re: [PATCH] x86/kprobe: Fix crash when probe cs call
Google
[PATCH v6 00/12] dma-buf: heaps: Add support for Tegra VPR
Thierry Reding
[PATCH v6 02/12] dt-bindings: display: tegra: Document memory regions
Thierry Reding
Re: [PATCH v6 02/12] dt-bindings: display: tegra: Document memory regions
sashiko-bot
[PATCH v6 04/12] arm64/mm: Export set_direct_map_*_noflush() APIs
Thierry Reding
Re: [PATCH v6 04/12] arm64/mm: Export set_direct_map_*_noflush() APIs
sashiko-bot
Re: [PATCH v6 04/12] arm64/mm: Export set_direct_map_*_noflush() APIs
Christoph Hellwig
[PATCH v6 08/12] dma-buf: heaps: Add debugfs support
Thierry Reding
Re: [PATCH v6 08/12] dma-buf: heaps: Add debugfs support
sashiko-bot
Re: [PATCH v6 08/12] dma-buf: heaps: Add debugfs support
Christian König
Re: [PATCH v6 08/12] dma-buf: heaps: Add debugfs support
Thierry Reding
[PATCH v6 09/12] dma-buf: heaps: Add support for Tegra VPR
Thierry Reding
Re: [PATCH v6 09/12] dma-buf: heaps: Add support for Tegra VPR
sashiko-bot
Re: [PATCH v6 09/12] dma-buf: heaps: Add support for Tegra VPR
Rob Herring
[PATCH v6 06/12] of: Export of_node_to_nid()
Thierry Reding
Re: [PATCH v6 06/12] of: Export of_node_to_nid()
sashiko-bot
Re: [PATCH v6 06/12] of: Export of_node_to_nid()
Rob Herring
[PATCH v6 03/12] dt-bindings: gpu: host1x: Document memory-regions for NVDEC
Thierry Reding
Re: [PATCH v6 03/12] dt-bindings: gpu: host1x: Document memory-regions for NVDEC
sashiko-bot
Re: [PATCH v6 03/12] dt-bindings: gpu: host1x: Document memory-regions for NVDEC
Thierry Reding
[PATCH v6 10/12] arm64: tegra: Add VPR placeholder node on Tegra234
Thierry Reding
Re: [PATCH v6 10/12] arm64: tegra: Add VPR placeholder node on Tegra234
sashiko-bot
[PATCH v6 01/12] dt-bindings: reserved-memory: Document Tegra VPR
Thierry Reding
Re: [PATCH v6 01/12] dt-bindings: reserved-memory: Document Tegra VPR
sashiko-bot
[PATCH v6 05/12] bitmap: Add bitmap_allocate() function
Thierry Reding
Re: [PATCH v6 05/12] bitmap: Add bitmap_allocate() function
sashiko-bot
[PATCH v6 11/12] arm64: tegra: Hook up VPR to host1x
Thierry Reding
Re: [PATCH v6 11/12] arm64: tegra: Hook up VPR to host1x
sashiko-bot
[PATCH v6 12/12] arm64: tegra: Add VPR placeholder node on Tegra264
Thierry Reding
Re: [PATCH v6 12/12] arm64: tegra: Add VPR placeholder node on Tegra264
sashiko-bot
Re: [PATCH v6 00/12] dma-buf: heaps: Add support for Tegra VPR
Will Deacon
Re: [PATCH v6 00/12] dma-buf: heaps: Add support for Tegra VPR
Thierry Reding
Re: [PATCH v6 00/12] dma-buf: heaps: Add support for Tegra VPR
Thierry Reding
Re: [PATCH v6 00/12] dma-buf: heaps: Add support for Tegra VPR
Vincent Donnefort
Re: [PATCH v6 00/12] dma-buf: heaps: Add support for Tegra VPR
Thierry Reding
Re: [PATCH v6 00/12] dma-buf: heaps: Add support for Tegra VPR
Vincent Donnefort
[PATCH v6 07/12] mm/cma: Introduce cma_alloc_at() API
Thierry Reding
Re: [PATCH v6 07/12] mm/cma: Introduce cma_alloc_at() API
sashiko-bot
Re: [PATCH v6 07/12] mm/cma: Introduce cma_alloc_at() API
Marek Szyprowski
[PATCH 0/8] mm: introduce for_each_process_rcu and for_each_thread_rcu
Ye Liu
[PATCH 5/8] kernel: convert process/thread iterators to for_each_*_rcu
Ye Liu
Re: [PATCH 5/8] kernel: convert process/thread iterators to for_each_*_rcu
sashiko-bot
Re: [PATCH 5/8] kernel: convert process/thread iterators to for_each_*_rcu
Günther Noack
Earlier messages
Later messages