On Tue, 12 Sep 2023 10:58:08 +0800
Jinjie Ruan <[email protected]> wrote:
This looks good. But I have a small nit.
> diff --git a/kernel/trace/trace_events.c b/kernel/trace/trace_events.c
> index ed367d713be0..8e0593d4c6a6 100644
> --- a/kernel/trace/trace_events.c
> +++ b/kernel/trace/trace_events.c
> @@ -2296,6 +2296,7 @@ event_subsystem_dir(struct trace_array *tr, const char
> *name,
> struct trace_event_file *file, struct dentry *parent)
> {
> struct event_subsystem *system, *iter;
> + struct eventfs_file *ef;
> struct trace_subsystem_dir *dir;
> int res;
>
Can you move the ef below dir to keep the "upside-down x-mas tree" format:
struct event_subsystem *system, *iter;
struct trace_subsystem_dir *dir;
struct eventfs_file *ef;
int res;
That's easier to read.
Thanks!
-- Steve