On Thu, 10 Oct 2024 14:25:11 +0200 Tomas Glozar <[email protected]> wrote:
> > --- a/tools/tracing/rtla/src/utils.c > > +++ b/tools/tracing/rtla/src/utils.c > > @@ -229,7 +229,7 @@ long parse_ns_duration(char *val) > > > > #define SCHED_DEADLINE 6 > > > > -static inline int sched_setattr(pid_t pid, const struct sched_attr *attr, > > +static inline int rtla_sched_setattr(pid_t pid, const struct sched_attr > > *attr, > > Hmm, rtla_sched_attr sounds to me like the function does something > specific to rtla. Maybe syscall_sched_attr would be a better name? Should I be waiting for a v2 with this addressed? -- Steve
