On 5/23/25 17:57, Mickaël Salaün wrote:
[RFC PATCH v1 1/5] landlock: Rename landlock_id to landlock_rule_ref

This avoids confusion with the new Landlock IDs.

A very very minor suggestion, but I think to someone new, landlock_rule_ref would sound like a reference to a specific rule (like a *struct landlock_rule), but really it represents the "name", or in fact, target of a rule... Maybe we should call it "landlock_rule_target"?

(Or maybe the confusion is resolved quickly when they look at the definition so maybe it doesn't matter)


TODO: Split in several commits to ease potential backports according to
stable branches

Cc: Günther Noack <[email protected]>
Signed-off-by: Mickaël Salaün <[email protected]>
---
[...]

Reply via email to