On 6/19/2026 8:31 AM, Ackerley Tng via B4 Relay wrote:
-bool kvm_range_has_memory_attributes(struct kvm *kvm, gfn_t start, gfn_t end,
-                                    unsigned long mask, unsigned long attrs);
+bool kvm_range_has_vm_memory_attributes(struct kvm *kvm, gfn_t start, gfn_t 
end,
+                                       unsigned long mask, unsigned long 
attrs);
  bool kvm_arch_pre_set_memory_attributes(struct kvm *kvm,
                                        struct kvm_gfn_range *range);
  bool kvm_arch_post_set_memory_attributes(struct kvm *kvm,

We have

 - kvm_pre_set_memory_attributes()
 - kvm_arch_pre_set_memory_attributes()
 - kvm_arch_post_set_memory_attributes()

left, do they need to be renamed as well?

then the interesting one is kvm_vm_set_mem_attributes(), which contains "vm" already while it means "vm ioctl". Do we need to rename it to
kvm_vm_set_vm_mem_attributes()?


Reply via email to