On Tue, Jun 30, 2026 at 05:32:03PM +0100, Pedro Falcato wrote:
> On Mon, Jun 29, 2026 at 01:23:20PM +0100, Lorenzo Stoakes wrote:
> > Similar to what we did with mapping_interval_tree*(), let's declare
> > anon_vma_interval_tree*() in terms of anon_vma rather than rb_root_cached.
> >
> > In each case the rb tree referenced is &anon_vma->rb_root, so just pass
> > anon_vma and the functions can figure this out themselves.
> >
> > Additionally, rename 'node' to 'avc', 'index' to 'pgoff_start', and 'last'
> > to 'pgoff_last' to make clear what is being passed.
> >
> > Finally express page offsets in terms of pgoff_t to be consistent.
> >
> > No functional change intended.
> >
> > Signed-off-by: Lorenzo Stoakes <[email protected]>
>
> Yay!
>
> Reviewed-by: Pedro Falcato <[email protected]>

Thanks :)

>
> I have a vaguely similar comment as for the file part (names could be
> simpler, doesn't really matter whether it's an interval tree or possibly
> even a tree), but I care less strongly about anon rmap :)

And yeah ack, let me agonise over that a bit :P

>
> --
> Pedro

Cheers, Lorenzo

Reply via email to