On 7/29/2026 8:35 AM, Ackerley Tng via B4 Relay wrote:
From: Sean Christopherson<[email protected]>
Rename memory attribute APIs to add a "vm_" in the name in anticipation of
moving PRIVATE tracking into guest_memfd, to allow in-place conversion
between SHARED and PRIVATE. At that point, there will effectively be two
(potential) sources of memory attributes: the VM and guest_memfd.
kvm_vm_set_mem_attributes() already has "vm" in the name to indicate that
it is a VM ioctl. Rename it to kvm_set_vm_mem_attributes() to show that it
is setting the VM's memory attributes. (Drop the VM-ioctl scoping since it
is a helper local to the file.) Update the accompanying trace function to
match.
No functional change intended.
Signed-off-by: Sean Christopherson<[email protected]>
Reviewed-by: Fuad Tabba<[email protected]>
Tested-by: Shivank Garg<[email protected]>
Signed-off-by: Ackerley Tng<[email protected]>
Reviewed-by: Xiaoyao Li <[email protected]>