linux-trace-kernel
Thread
Date
Earlier messages
Later messages
Messages by Thread
[PATCH v12 32/45] KVM: selftests: Test conversion precision in guest_memfd
Ackerley Tng via B4 Relay
[PATCH v12 34/45] KVM: selftests: Convert with allocated folios in different layouts
Ackerley Tng via B4 Relay
[PATCH v12 31/45] KVM: selftests: Test conversion flow when INIT_SHARED
Ackerley Tng via B4 Relay
[PATCH v12 39/45] KVM: selftests: Reset shared memory after hole-punching
Ackerley Tng via B4 Relay
[PATCH v12 38/45] KVM: selftests: Test conversion with elevated page refcount
Ackerley Tng via B4 Relay
[PATCH v12 40/45] KVM: selftests: Provide function to look up guest_memfd details from gpa
Ackerley Tng via B4 Relay
[PATCH v12 37/45] KVM: selftests: Add helpers to pin pages with CONFIG_GUP_TEST
Ackerley Tng via B4 Relay
Re: [PATCH v3 0/2] tracing: Remove trace_printk.h from kernel.h
Yury Norov
Re: [PATCH v3 0/2] tracing: Remove trace_printk.h from kernel.h
Steven Rostedt
[PATCH v14 00/14] tracing: wprobe: x86: Add wprobe for watchpoint
Masami Hiramatsu (Google)
[PATCH v14 02/14] tracing/probes: Fix BTF kflag check for anonymous struct member access
Masami Hiramatsu (Google)
Re: [PATCH v14 02/14] tracing/probes: Fix BTF kflag check for anonymous struct member access
sashiko-bot
Re: [PATCH v14 02/14] tracing/probes: Fix BTF kflag check for anonymous struct member access
Google
[PATCH v14 01/14] x86/mce: Fix hardware debug register corruption on task migration
Masami Hiramatsu (Google)
Re: [PATCH v14 01/14] x86/mce: Fix hardware debug register corruption on task migration
sashiko-bot
[PATCH v14 11/14] tracing/wprobe: Add set_wprobe and clear_wprobe event triggers
Masami Hiramatsu (Google)
Re: [PATCH v14 11/14] tracing/wprobe: Add set_wprobe and clear_wprobe event triggers
sashiko-bot
[PATCH v14 12/14] selftests: ftrace: Add wprobe trigger testcase
Masami Hiramatsu (Google)
Re: [PATCH v14 12/14] selftests: ftrace: Add wprobe trigger testcase
sashiko-bot
[PATCH v14 04/14] x86/hw_breakpoints: Make DR7 updates NMI safe
Masami Hiramatsu (Google)
Re: [PATCH v14 04/14] x86/hw_breakpoints: Make DR7 updates NMI safe
sashiko-bot
[PATCH v14 03/14] kprobes: Protect kprobe_blacklist with RCU
Masami Hiramatsu (Google)
Re: [PATCH v14 03/14] kprobes: Protect kprobe_blacklist with RCU
sashiko-bot
Re: [PATCH v14 03/14] kprobes: Protect kprobe_blacklist with RCU
Google
[PATCH v14 06/14] HWBP: Add modify_local_hw_breakpoint_addr() API
Masami Hiramatsu (Google)
Re: [PATCH v14 06/14] HWBP: Add modify_local_hw_breakpoint_addr() API
sashiko-bot
[PATCH v14 09/14] selftests: tracing: Add a basic testcase for wprobe
Masami Hiramatsu (Google)
Re: [PATCH v14 09/14] selftests: tracing: Add a basic testcase for wprobe
sashiko-bot
[PATCH v14 13/14] tracing/wprobe: Support BTF typecast in fetchargs
Masami Hiramatsu (Google)
Re: [PATCH v14 13/14] tracing/wprobe: Support BTF typecast in fetchargs
sashiko-bot
[PATCH v14 07/14] tracing/wprobe: Add wprobe (watchpoint probe) trace event support
Masami Hiramatsu (Google)
Re: [PATCH v14 07/14] tracing/wprobe: Add wprobe (watchpoint probe) trace event support
sashiko-bot
[PATCH v14 10/14] selftests: tracing: Add syntax testcase for wprobe
Masami Hiramatsu (Google)
Re: [PATCH v14 10/14] selftests: tracing: Add syntax testcase for wprobe
sashiko-bot
[PATCH v14 08/14] x86: hw_breakpoint: Add a kconfig to clarify when a breakpoint fires
Masami Hiramatsu (Google)
Re: [PATCH v14 08/14] x86: hw_breakpoint: Add a kconfig to clarify when a breakpoint fires
sashiko-bot
[PATCH v14 14/14] tracing/wprobe: Support BTF struct offset resolution in set_wprobe trigger
Masami Hiramatsu (Google)
Re: [PATCH v14 14/14] tracing/wprobe: Support BTF struct offset resolution in set_wprobe trigger
sashiko-bot
[PATCH v14 05/14] x86/hw_breakpoints: Add arch_modify_local_hw_breakpoint_addr() API
Masami Hiramatsu (Google)
Re: [PATCH v14 05/14] x86/hw_breakpoints: Add arch_modify_local_hw_breakpoint_addr() API
sashiko-bot
[PATCH v2] riscv: mm: Trace TLB flush path selection
Roman 'Hedin' Storozhenko
[RFC PATCH 0/4] ftrace: Add task comm filtering for function tracing
hu.shengming
[RFC PATCH 1/4] ftrace: Generalize function task filter names
hu.shengming
[RFC PATCH 2/4] ftrace: Centralize task filter state updates
hu.shengming
Re: [RFC PATCH 2/4] ftrace: Centralize task filter state updates
sashiko-bot
[RFC PATCH 3/4] ftrace: Add exact task comm filtering
hu.shengming
[RFC PATCH 4/4] Documentation/ftrace: Document function comm filters
hu.shengming
Re: [RFC PATCH 4/4] Documentation/ftrace: Document function comm filters
Randy Dunlap
Re: [RFC PATCH 4/4] Documentation/ftrace: Document function comm filters
hu.shengming
Re: [RFC PATCH 0/4] ftrace: Add task comm filtering for function tracing
Google
Re: [RFC PATCH 0/4] ftrace: Add task comm filtering for function tracing
hu.shengming
Re: [RFC PATCH 0/4] ftrace: Add task comm filtering for function tracing
Steven Rostedt
Re: [RFC PATCH 0/4] ftrace: Add task comm filtering for function tracing
hu.shengming
[PATCH 0/3] workqueue: Add telemetry tracepoints for CPU hogs, distress, and BH budget yields
Aaron Tomlin
[PATCH 1/3] workqueue: Add workqueue_cpu_intensive tracepoint
Aaron Tomlin
Re: [PATCH 1/3] workqueue: Add workqueue_cpu_intensive tracepoint
sashiko-bot
[PATCH 3/3] workqueue: Add workqueue_bh_budget_yield tracepoint
Aaron Tomlin
Re: [PATCH 3/3] workqueue: Add workqueue_bh_budget_yield tracepoint
kernel test robot
[PATCH 2/3] workqueue: Add workqueue_mayday and workqueue_rescued tracepoints
Aaron Tomlin
Re: [PATCH 0/3] workqueue: Add telemetry tracepoints for CPU hogs, distress, and BH budget yields
Tejun Heo
[PATCH] riscv: mm: Trace TLB flush path selection
Roman 'Hedin' Storozhenko
Re: [PATCH] riscv: mm: Trace TLB flush path selection
Steven Rostedt
Re: [PATCH] riscv: mm: Trace TLB flush path selection
Roman Storozhenko
Re: [PATCH] riscv: ftrace: only use pre-function NOPs with call ops
Rui Qi
[PATCH v2] ftrace: Take trace_array reference before accessing its ftrace_ops
Steven Rostedt
Re: [PATCH v2] ftrace: Take trace_array reference before accessing its ftrace_ops
sashiko-bot
Re: [PATCH v2] ftrace: Take trace_array reference before accessing its ftrace_ops
Steven Rostedt
Re: [PATCH v2] ftrace: Take trace_array reference before accessing its ftrace_ops
Breno Leitao
[PATCH] ftrace: Take trace_array reference before accessing its ftrace_ops
Steven Rostedt
Re: [PATCH] ftrace: Take trace_array reference before accessing its ftrace_ops
sashiko-bot
Re: [PATCH] ftrace: Take trace_array reference before accessing its ftrace_ops
Steven Rostedt
[PATCH] tracing: Have show_event_filters/triggers files take trace array ref
Steven Rostedt
Re: [PATCH] tracing: Have show_event_filters/triggers files take trace array ref
sashiko-bot
Re: [PATCH] tracing: Have show_event_filters/triggers files take trace array ref
Aaron Tomlin
ftrace: UAF in ftrace_regex_open() on a removed tracing instance
Breno Leitao
Re: ftrace: UAF in ftrace_regex_open() on a removed tracing instance
Steven Rostedt
Re: ftrace: UAF in ftrace_regex_open() on a removed tracing instance
Breno Leitao
Re: ftrace: UAF in ftrace_regex_open() on a removed tracing instance
Steven Rostedt
Re: ftrace: UAF in ftrace_regex_open() on a removed tracing instance
Steven Rostedt
Re: ftrace: UAF in ftrace_regex_open() on a removed tracing instance
Steven Rostedt
Re: ftrace: UAF in ftrace_regex_open() on a removed tracing instance
Steven Rostedt
[syzbot] [trace?] [block?] KASAN: slab-use-after-free Read in blk_log_remap
syzbot
[BUG] tracing: use-after-free in t_start() when a trace instance is removed
Farhad Alemi
Re: [BUG] tracing: use-after-free in t_start() when a trace instance is removed
Steven Rostedt
Re: [BUG] tracing: use-after-free in t_start() when a trace instance is removed
Steven Rostedt
Re: [BUG] tracing: use-after-free in t_start() when a trace instance is removed
Steven Rostedt
[PATCH v3] tracing/user_events: Clear copied tracing state before fork duplication
Jérémy Jean
[PATCH v5 0/6] sched: Add support for long task name
André Almeida
[PATCH v5 4/6] sched: Extend task command name with TASK_COMM_EXT_LEN
André Almeida
Re: [PATCH v5 4/6] sched: Extend task command name with TASK_COMM_EXT_LEN
sashiko-bot
[PATCH v5 5/6] prctl: Add support for long user thread names
André Almeida
Re: [PATCH v5 5/6] prctl: Add support for long user thread names
sashiko-bot
[PATCH v5 6/6] selftests: prctl: Add test for long thread names
André Almeida
Re: [PATCH v5 6/6] selftests: prctl: Add test for long thread names
sashiko-bot
Re: [PATCH v5 6/6] selftests: prctl: Add test for long thread names
kernel test robot
Re: [PATCH v5 6/6] selftests: prctl: Add test for long thread names
kernel test robot
[PATCH v5 2/6] treewide: Replace memcpy(..., current->comm) with copy_task_comm()
André Almeida
Re: [PATCH v5 2/6] treewide: Replace memcpy(..., current->comm) with copy_task_comm()
sashiko-bot
[PATCH v5 3/6] lib/string_kunit: Add test for copy_task_comm()
André Almeida
Re: [PATCH v5 3/6] lib/string_kunit: Add test for copy_task_comm()
sashiko-bot
[PATCH v5 1/6] treewide: Get rid of get_task_comm()
André Almeida
Re: [PATCH v5 1/6] treewide: Get rid of get_task_comm()
sashiko-bot
[PATCH v4 0/4] rv/reactors: fix lockdep warning and add KUnit tests
wen . yang
[PATCH v4 4/4] rv/reactors: add KUnit tests for reactor registration and dispatch
wen . yang
Re: [PATCH v4 4/4] rv/reactors: add KUnit tests for reactor registration and dispatch
sashiko-bot
[PATCH v4 3/4] rv/reactors: export rv_register_reactor() and rv_unregister_reactor()
wen . yang
Re: [PATCH v4 3/4] rv/reactors: export rv_register_reactor() and rv_unregister_reactor()
sashiko-bot
[PATCH v4 2/4] rv/reactors: propagate rv_register_reactor() error from reactor init
wen . yang
[PATCH v4 1/4] rv/reactors: use LD_WAIT_SPIN as the reactor lockdep wait type
wen . yang
Re: [PATCH v4 1/4] rv/reactors: use LD_WAIT_SPIN as the reactor lockdep wait type
sashiko-bot
Re: [PATCH v4 1/4] rv/reactors: use LD_WAIT_SPIN as the reactor lockdep wait type
Gabriele Monaco
[RFC 0/3] rv: per-edge dwell-time statistics for per-cpu monitors
Tobias Schaffner
[RFC 2/3] rv: add per-monitor edge-stat facility and stats file
Tobias Schaffner
Re: [RFC 2/3] rv: add per-monitor edge-stat facility and stats file
sashiko-bot
Re: [RFC 2/3] rv: add per-monitor edge-stat facility and stats file
Gabriele Monaco
[RFC 1/3] rv: add per-edge dwell-time statistics primitive
Tobias Schaffner
Re: [RFC 1/3] rv: add per-edge dwell-time statistics primitive
sashiko-bot
Re: [RFC 1/3] rv: add per-edge dwell-time statistics primitive
Gabriele Monaco
Re: [RFC 1/3] rv: add per-edge dwell-time statistics primitive
Tobias Schaffner
Re: [RFC 1/3] rv: add per-edge dwell-time statistics primitive
Gabriele Monaco
[RFC 3/3] rv: collect per-edge dwell time for per-cpu DA/HA monitors
Tobias Schaffner
Re: [RFC 3/3] rv: collect per-edge dwell time for per-cpu DA/HA monitors
sashiko-bot
Re: [RFC 0/3] rv: per-edge dwell-time statistics for per-cpu monitors
Gabriele Monaco
Re: [RFC 0/3] rv: per-edge dwell-time statistics for per-cpu monitors
Tobias Schaffner
[PATCH v2] tracing/user_events: Clear copied tracing state before fork duplication
Jérémy Jean
Re: [PATCH v2] tracing/user_events: Clear copied tracing state before fork duplication
Bradley Morgan
Re: [PATCH v2] tracing/user_events: Clear copied tracing state before fork duplication
Jérémy Jean
Re: [PATCH v2] tracing/user_events: Clear copied tracing state before fork duplication
Bradley Morgan
Re: [PATCH v2] tracing/user_events: Clear copied tracing state before fork duplication
Steven Rostedt
Re: [PATCH v2] tracing/user_events: Clear copied tracing state before fork duplication
Bradley Morgan
Re: [PATCH v2] tracing/user_events: Clear copied tracing state before fork duplication
Steven Rostedt
Re: [PATCH v2] tracing/user_events: Clear copied tracing state before fork duplication
Bradley Morgan
Re: [PATCH v2] tracing/user_events: Clear copied tracing state before fork duplication
Steven Rostedt
Re: [PATCH v2] tracing/user_events: Clear copied tracing state before fork duplication
Jérémy Jean
Re: [PATCH v2] tracing/user_events: Clear copied tracing state before fork duplication
Bradley Morgan
Re: [PATCH v2] tracing/user_events: Clear copied tracing state before fork duplication
Steven Rostedt
Re: [PATCH v2] tracing/user_events: Clear copied tracing state before fork duplication
Bradley Morgan
Re: [PATCH v2] tracing/user_events: Clear copied tracing state before fork duplication
Steven Rostedt
Re: [PATCH v2] tracing/user_events: Clear copied tracing state before fork duplication
Bradley Morgan
[PATCH v8 0/3] ring-buffer: Fixes for subbuf resizing and persistent buffers
Vincent Donnefort
[PATCH v8 1/3] tracing: Fix subbuf resize races with trace_pipe_raw readers
Vincent Donnefort
Re: [PATCH v8 1/3] tracing: Fix subbuf resize races with trace_pipe_raw readers
sashiko-bot
Re: [PATCH v8 1/3] tracing: Fix subbuf resize races with trace_pipe_raw readers
Steven Rostedt
Re: [PATCH v8 1/3] tracing: Fix subbuf resize races with trace_pipe_raw readers
Vincent Donnefort
Re: [PATCH v8 1/3] tracing: Fix subbuf resize races with trace_pipe_raw readers
Steven Rostedt
Re: [PATCH v8 1/3] tracing: Fix subbuf resize races with trace_pipe_raw readers
Vincent Donnefort
Re: [PATCH v8 1/3] tracing: Fix subbuf resize races with trace_pipe_raw readers
Steven Rostedt
Re: [PATCH v8 1/3] tracing: Fix subbuf resize races with trace_pipe_raw readers
Vincent Donnefort
Re: [PATCH v8 1/3] tracing: Fix subbuf resize races with trace_pipe_raw readers
Steven Rostedt
Re: [PATCH v8 1/3] tracing: Fix subbuf resize races with trace_pipe_raw readers
Vincent Donnefort
Re: [PATCH v8 1/3] tracing: Fix subbuf resize races with trace_pipe_raw readers
Steven Rostedt
[PATCH v8 2/3] ring-buffer: Cap static ring buffer nr_pages
Vincent Donnefort
[PATCH v8 3/3] ring-buffer: Prevent truncation of nr_pages / nr_subbufs
Vincent Donnefort
Re: [PATCH v8 3/3] ring-buffer: Prevent truncation of nr_pages / nr_subbufs
sashiko-bot
[PATCH 0/2] driver core: add TAINT_FORCED_BIND for when userspace manually messes with devices and drivers
Greg Kroah-Hartman
[PATCH 2/2] driver core: add TAINT_FORCED_BIND for when userspace manually messes with devices and drivers
Greg Kroah-Hartman
Re: [PATCH 2/2] driver core: add TAINT_FORCED_BIND for when userspace manually messes with devices and drivers
sashiko-bot
Re: [PATCH 2/2] driver core: add TAINT_FORCED_BIND for when userspace manually messes with devices and drivers
Bradley Morgan
Re: [PATCH 2/2] driver core: add TAINT_FORCED_BIND for when userspace manually messes with devices and drivers
Greg KH
Re: [PATCH 2/2] driver core: add TAINT_FORCED_BIND for when userspace manually messes with devices and drivers
Steven Rostedt
Re: [PATCH 2/2] driver core: add TAINT_FORCED_BIND for when userspace manually messes with devices and drivers
Bradley Morgan
Re: [PATCH 2/2] driver core: add TAINT_FORCED_BIND for when userspace manually messes with devices and drivers
Johan Hovold
[PATCH 1/2] module: pull out add_taint_module() to be public
Greg Kroah-Hartman
Re: [PATCH 1/2] module: pull out add_taint_module() to be public
sashiko-bot
Re: [PATCH 1/2] module: pull out add_taint_module() to be public
Greg Kroah-Hartman
Re: [PATCH 1/2] module: pull out add_taint_module() to be public
Aaron Tomlin
Re: [PATCH 1/2] module: pull out add_taint_module() to be public
Greg Kroah-Hartman
Re: [PATCH 1/2] module: pull out add_taint_module() to be public
Johan Hovold
Re: [PATCH 1/2] module: pull out add_taint_module() to be public
Greg Kroah-Hartman
Re: [PATCH 0/2] driver core: add TAINT_FORCED_BIND for when userspace manually messes with devices and drivers
Michal Pecio
Re: [PATCH 0/2] driver core: add TAINT_FORCED_BIND for when userspace manually messes with devices and drivers
Greg Kroah-Hartman
Re: [PATCH 0/2] driver core: add TAINT_FORCED_BIND for when userspace manually messes with devices and drivers
Michal Pecio
Re: [PATCH 0/2] driver core: add TAINT_FORCED_BIND for when userspace manually messes with devices and drivers
Greg Kroah-Hartman
Re: [PATCH 0/2] driver core: add TAINT_FORCED_BIND for when userspace manually messes with devices and drivers
Michal Pecio
[PATCH v11 00/46] guest_memfd: In-place conversion support
Ackerley Tng
[PATCH v11 03/46] KVM: guest_memfd: Introduce per-gmem attributes, use to guard user mappings
Ackerley Tng
[PATCH v11 08/46] KVM: Provide generic interface for checking memory private/shared status
Ackerley Tng
[PATCH v11 07/46] KVM: Rename kvm_mem_is_private() to kvm_is_private_gfn()
Ackerley Tng
[PATCH v11 09/46] KVM: guest_memfd: Stub in ability to enable in-place shared<=>private conversion
Ackerley Tng
[PATCH v11 01/46] KVM: guest_memfd: Optimize away conversion overheads via dead-code elimination
Ackerley Tng
[PATCH v11 12/46] KVM: guest_memfd: Pass mapping type filter to invalidation helper
Ackerley Tng
[PATCH v11 02/46] KVM: guest_memfd: Use kvm_mem_is_private() when populating guest_memfd memory
Ackerley Tng
[PATCH v11 04/46] KVM: Rename KVM_GENERIC_MEMORY_ATTRIBUTES to KVM_VM_MEMORY_ATTRIBUTES
Ackerley Tng
[PATCH v11 05/46] KVM: Enumerate support for PRIVATE memory iff kvm_arch_has_private_mem is defined
Ackerley Tng
[PATCH v11 15/46] KVM: guest_memfd: Call arch make_shared callback for to-shared conversion
Ackerley Tng
Re: [PATCH v11 15/46] KVM: guest_memfd: Call arch make_shared callback for to-shared conversion
Sean Christopherson
Re: [PATCH v11 15/46] KVM: guest_memfd: Call arch make_shared callback for to-shared conversion
Michael Roth
Re: [PATCH v11 15/46] KVM: guest_memfd: Call arch make_shared callback for to-shared conversion
Sean Christopherson
Re: [PATCH v11 15/46] KVM: guest_memfd: Call arch make_shared callback for to-shared conversion
Michael Roth
Re: [PATCH v11 15/46] KVM: guest_memfd: Call arch make_shared callback for to-shared conversion
Sean Christopherson
Re: [PATCH v11 15/46] KVM: guest_memfd: Call arch make_shared callback for to-shared conversion
Ackerley Tng
Re: [PATCH v11 15/46] KVM: guest_memfd: Call arch make_shared callback for to-shared conversion
Sean Christopherson
[PATCH v11 06/46] KVM: Rename memory attribute APIs to prepare for in-place gmem conversion
Ackerley Tng
[PATCH v11 16/46] KVM: guest_memfd: Return early if range already has requested attributes
Ackerley Tng
[PATCH v11 11/46] KVM: guest_memfd: Invalidate both SHARED and PRIVATE mappings for in-place conversions
Ackerley Tng
[PATCH v11 14/46] KVM: guest_memfd: Ensure pages are not in use before conversion
Ackerley Tng
[PATCH v11 13/46] KVM: guest_memfd: Add base support for KVM_SET_MEMORY_ATTRIBUTES2
Ackerley Tng
[PATCH v11 18/46] KVM: guest_memfd: Handle lru_add fbatch refcounts during conversion safety check
Ackerley Tng
[PATCH v11 20/46] KVM: SEV: Make 'uaddr' parameter optional for KVM_SEV_SNP_LAUNCH_UPDATE
Ackerley Tng
[PATCH v11 27/46] KVM: selftests: Add support for mmap() on guest_memfd in core library
Ackerley Tng
Earlier messages
Later messages