On 8/31/2026 8:25 AM, Ackerley Tng via B4 Relay wrote: > From: Ackerley Tng <[email protected]> > > Rename kvm_mem_is_private() to kvm_is_private_gfn() to prepare for in-place > conversion, where there will be two lookup functions, > kvm_vm_is_private_gfn() and kvm_gmem_is_private_gfn(). > > This renaming allows consistent prefixing of "vm" vs "gmem" for > kvm_*_is_private_gfn(), as opposed to kvm_gmem_mem_is_private(), which > looks like a typo. > > Suggested-by: Sean Christopherson <[email protected]> > Signed-off-by: Ackerley Tng <[email protected]> Reviewed-by: Binbin Wu <[email protected]>
- [PATCH v12 09/45] KVM: guest_memfd: Stub in abil... Ackerley Tng via B4 Relay
- [PATCH v12 06/45] KVM: Rename memory attribute A... Ackerley Tng via B4 Relay
- [PATCH v12 05/45] KVM: Enumerate support for PRI... Ackerley Tng via B4 Relay
- [PATCH v12 01/45] KVM: guest_memfd: Optimize awa... Ackerley Tng via B4 Relay
- [PATCH v12 07/45] KVM: Rename kvm_mem_is_private... Ackerley Tng via B4 Relay
- Re: [PATCH v12 07/45] KVM: Rename kvm_mem_i... Fuad Tabba
- Re: [PATCH v12 07/45] KVM: Rename kvm_mem_i... Binbin Wu
- [PATCH v12 12/45] KVM: guest_memfd: Always fault... Ackerley Tng via B4 Relay
- [PATCH v12 10/45] KVM: Consolidate private memor... Ackerley Tng via B4 Relay
- [PATCH v12 11/45] KVM: guest_memfd: Invalidate b... Ackerley Tng via B4 Relay
- [PATCH v12 13/45] KVM: guest_memfd: Pass mapping... Ackerley Tng via B4 Relay
- [PATCH v12 16/45] KVM: guest_memfd: Call arch ma... Ackerley Tng via B4 Relay
- [PATCH v12 26/45] KVM: selftests: Rename guest_m... Ackerley Tng via B4 Relay
- [PATCH v12 14/45] KVM: guest_memfd: Add base sup... Ackerley Tng via B4 Relay
