On 2026-09-03 2:53 p.m., [email protected] wrote: > From: Frank Li <[email protected]> > > Introduce vchan_chan_name() to obtain the DMA channel device name. > > Use a dedicated helper instead of directly accessing dma_chan::dev > so callers remain unaffected by an upcoming rename of the struct member. > > Signed-off-by: Frank Li <[email protected]> Makes sense to me: Reviewed-by: Logan Gunthorpe <[email protected]>
- [PATCH v2 0/3] dmaengine: rename dma_chan::dev to dma_chan... Frank . Li
- [PATCH v2 1/3] dmaengine: vchan: add vchan_chan_name(... Frank . Li
- Re: [PATCH v2 1/3] dmaengine: vchan: add vchan_ch... sashiko-bot
- Re: [PATCH v2 1/3] dmaengine: vchan: add vchan_ch... Logan Gunthorpe
- Re: [PATCH v2 1/3] dmaengine: vchan: add vchan_ch... Amelie Delaunay
- Re: [Linux-stm32] [PATCH v2 1/3] dmaengine: v... Amelie Delaunay
- Re: [PATCH v2 1/3] dmaengine: vchan: add vchan_ch... Andy Shevchenko
- Re: [PATCH v2 1/3] dmaengine: vchan: add vcha... Amelie Delaunay
- Re: [PATCH v2 1/3] dmaengine: vchan: add ... Andy Shevchenko
- [PATCH v2 2/3] dmaengine: use dma_chan_name() helper ... Frank . Li
- [PATCH v2 3/3] dmaengine: add union chan_dev for dma_... Frank . Li
