On 10/13/26 17:04, Lorenzo Stoakes (ARM) wrote: > Replace the open-coded VMA_SPECIAL_FLAGS check in the VMA merge logic with > two new functions vma_flags_can_merge() and vma_can_merge() and update the > merge logic to use the former. > > This abstracts the check and expresses it in terms of the desired behaviour > rather than an arbitrary and confusing VMA flag. > > This also lays the groundwork for making further improvements in VMA flag > usage. > > Also update the userland VMA tests to reflect the change. > > No functional change intended. > > Reviewed-by: Gregory Price (Meta) <[email protected]> > Reviewed-by: Zi Yan <[email protected]> > Reviewed-by: Suren Baghdasaryan <[email protected]> > Acked-by: David Hildenbrand (Arm) <[email protected]> > Signed-off-by: Lorenzo Stoakes (ARM) <[email protected]> > ---
I'd have called it "vma_mergable" etc, because "can_merge" makes me imply a "with what". Acked-by: David Hildenbrand (Arm) <[email protected]> -- Cheers, David
