On June 23, 2026 9:14:52 PM GMT+01:00, Andy Shevchenko <[email protected]> wrote: >On Tue, Jun 23, 2026 at 11:11:34PM +0300, Andy Shevchenko wrote: >> On Tue, Jun 23, 2026 at 03:34:58PM +0000, Bradley Morgan wrote: >> > Some callers handle SYS_INFO_ALL_BT themselves before calling >sys_info(). >> > Add a helper that strips that bit without turning an all_bt only mask >into >> > a kernel_sys_info fallback. >> >> You also want a getter with check >> >> bool sysinfo_is_all_bt_enabled(..., *si_mask) >> >> where *si_mask is the result of READ_ONCE() that you keep as >implementation >> detail inside this helper. > >Ah, sorry, I have thought that the mask is part of sysinfo implementation. >Disregard my above comment, it can't be done without also supplying the >pointer >to the original one, which makes no sense.
Ah, yeah, I was gonna say that. No worries, will disregard! :) > Thanks!
