On 25 June 2026 19:38:14 BST, Andrew Morton <[email protected]> wrote: >On Thu, 25 Jun 2026 17:30:15 +0200 Petr Mladek <[email protected]> wrote: > >> On Wed 2026-06-24 13:34:19, Andrew Morton wrote: >> > On Tue, 23 Jun 2026 15:34:58 +0000 Bradley Morgan <[email protected]> >wrote: >> > >> > > Some callers handle SYS_INFO_ALL_BT themselves before calling >sys_info(). >> > > Add a helper that strips that bit without turning an all_bt only >mask into >> > > a kernel_sys_info fallback. >> > >> > I assume this patch wants a Fixes: and a cc:stable also. >> > >> > It would be nice to have the conventional [0/N] cover letter to tell >> > readers what this is all about. >> > >> > The patches all have different Fixes: targets. This risks inviting >the >> > -stable maintainers to merge only some of the patches into some >> > kernels, resulting in an untested combination and which might break >> > things. >> >> I do not agree here. The Fixes tag should should point to a commit >> which introduced the regression into the given code. And finding >> some magic common point beause there is some magic undocumented >> process for maintaining stable kernels sounds like a way to hell >> to me. > >Well, as said, this potentially asks -stable maintainers to cherrypick >individual patches from this series into various kernel versions. >Potentially resulting in code combinations which nobody has tested. >Heck, the individual patches may not even compile. > >If we're to add the series to mainline as a single atomic lump then we >should add it to -stable as a single atomic lump, as that's the only >thing which has been tested. To communicate this to -stable >maintainers we can choose a Fixes: target to which the series can be >added as a single atomic lump. > >Of course, we could always discuss this with -stable maintainers ;) >
Hi Andrew, I ended up deciding on a generic fixes tag on V3, if you would like to have a look. Thanks!
