> On Jan 4, 2015, at 1:42 PM, Morten Christensen <mc-m...@g.mc.cx> wrote:
> Den 04-01-2015 kl. 18:57 skrev compdoc:
>>> Is it impossible to try to improve on pfSense 2.2's problem in pfSense
>> You might not be the only person having the problem, but I haven't
>> researched to know for sure.
>> Sometimes, it's possible to do the work and discover the problem yourself.
>> There are a few areas of experimentation that might lead to the problem, or
>> to the solution...
>> First of all, it's possible that there is a problem with that version of
>> pfSense. Something that may be fixed before or after its release.
>> Or, its possible there is a problem with the drivers for the virtual nics in
>> that version of freebsd. Guess that would be either the 100baseT Realtek NIC
>> emulation, or the xenserver NIC drivers if you have managed to install
>> those.
>> You can see if a better or newer driver exists. I have compiled realtek's
>> newest freebsd drivers myself and used them, for example.
> If I could find drivers, I have no idea, how to install them on pfSense.
>> If you were to try the e1000 emulation as suggested in the url I posted and
>> saw no improvement, that knowledge might be a great help to the community.
> I tried to make the cange from your link in the xenserver, and installed a 
> new pfSense 2.2.
> The pfSenses nic's ware called xn like before, so I have no idea, if it had 
> any effect.
> The iperf network speed from another VM on the same Xenserver through pfSense 
> was 1,4 Kbits/sec. As unusable as before with pfSense 2.2.
>> Finally, there's the actual server hardware itself. Its takes a certain
>> speed and type cpu to host virtual machine firewalls. Also, certain brands
>> of network cards perform better than others. Maybe you can describe these...
> It don't think it is the hardware.
> On the same hardware and the same Xenserver-install both pfSense 2.1, IPCop 
> and Zentyal is acting normal.
> It is only pfSense 2.2, that has this not usuable speed from other VM's in 
> the Xenserver.
> As said in the other thread. Speed from behind the xenserver is normal.

There is definitely something wrong with 2.2 under XenServer 6.2.  I’m seeing 
exactly the same thing as Morten.  To pfSense is fine.  Through pfSense is 

2.1.5 is fine but represents re adapters, not xn.  I have not tried from 
pfSense to a VM on the same vswitch yet.  Only through pfSense 2.2 to the WAN.

List mailing list

Reply via email to