> >  /**
> > + * Cipher algorithm capabilities
> > + */
> > +typedef struct odp_crypto_cipher_capa_t {
> > +       /** Key length in bytes */
> > +       uint32_t key_len;
> > +
> > +       /** IV length in bytes */
> > +       uint32_t iv_len;
> > +
> > +} odp_crypto_cipher_capa_t;
> 
> This should be odp_crypto_cipher_capability_t for consistency with
> other odp_xxx_capability_t types.

int odp_crypto_cipher_capability(odp_cipher_alg_t cipher,
                                           odp_crypto_cipher_capability_t 
capa[], int num);


It's getting rather long (28 char function name). For example, the line above 
does not fit into 80 chars any more. Also odp_cipher_alg_t is not 
odp_cipher_algorithm_t, but an abbreviation of that.

-Petri

Reply via email to