> >  /**
> > + * Initialize crypto session parameters
> > + *
> > + * Initialize an odp_crypto_session_params_t to its default values for
> > + * all fields.
> > + *
> > + * @param params   Pointer to odp_crypto_session_params_t to be
> initialized
> > + */
> > +void odp_crypto_session_params_init(odp_crypto_session_params_t
> *params);
> 
> Since we're cleaning up and adding this for completeness, the
> underlying struct should be changed to odp_crypto_session_param_t and
> this API should be odp_crypto_session_param_init() for consistency
> with all other odp_xxx_param_t and odp_xxx_param_init() functions. The
> inconsistent use of params instead of param in the crypto API was an
> oversight in Monarch.
>

It would be nice if only _param_t would be used throughout all APIs, but this 
would not be the only one to change. This is the list of all _params_t:

odp_crypto_session_params_t
odp_crypto_op_params_t

odp_tm_shaper_params_t
odp_tm_sched_params_t
odp_tm_threshold_params_t
odp_tm_wred_params_t
odp_tm_node_params_t
odp_tm_queue_params_t

odph_linux_thr_params_t
odph_odpthread_params_t


It's questionable if it pays off to rename 8 types in the API, since type name 
change is non-backward compatible and the gain is rather cosmetic / 
nice-to-have. I could deprecated old type names for crypto in this patch set 
and add new ones if everybody agrees.

-Petri

Reply via email to