On Wed, Dec 7, 2016 at 3:32 AM, Savolainen, Petri (Nokia - FI/Espoo)
<petri.savolai...@nokia-bell-labs.com> wrote:
>
>> >  /**
>> > + * Cipher algorithm capabilities
>> > + */
>> > +typedef struct odp_crypto_cipher_capa_t {
>> > +       /** Key length in bytes */
>> > +       uint32_t key_len;
>> > +
>> > +       /** IV length in bytes */
>> > +       uint32_t iv_len;
>> > +
>> > +} odp_crypto_cipher_capa_t;
>>
>> This should be odp_crypto_cipher_capability_t for consistency with
>> other odp_xxx_capability_t types.
>
> int odp_crypto_cipher_capability(odp_cipher_alg_t cipher,
>                                            odp_crypto_cipher_capability_t 
> capa[], int num);
>
>
> It's getting rather long (28 char function name). For example, the line above 
> does not fit into 80 chars any more. Also odp_cipher_alg_t is not 
> odp_cipher_algorithm_t, but an abbreviation of that.

I don't see a problem with adding a newline for readability here. The
use of 'alg' is Ok here (though spelling this out as algorithm would
be preferable), but we already have a set of odp_xxx_capability() APIs
so we should be consistent with that precedent when we introduce new
members to that "family".

>
> -Petri
>

Reply via email to