On Sat, Aug 11, 2018 at 10:05 PM, Fajar A. Nugraha <l...@fajar.net> wrote:

> On Sat, Aug 11, 2018 at 1:37 PM, Pierre Couderc <pie...@couderc.eu> wrote:
>
>> Trying to build lxd from sources, I get a message about sqlite3 missing,
>> and an invite to "make deps".
>>
>> But it fails too with :
>>
>>
>> No package 'sqlite3' found
>>
>> Consider adjusting the PKG_CONFIG_PATH environment variable if you
>> installed software in a non-standard prefix.
>>
>> Alternatively, you may set the environment variables sqlite_CFLAGS
>> and sqlite_LIBS to avoid the need to call pkg-config.
>> See the pkg-config man page for more details
>>
>>
>> And the man pkg-config is not clear to me...
>>
>>
> I believe the script basically needs this file:
> /usr/lib/pkgconfig/sqlite.pc
>
> On ubuntu 18.04, it's provided by libsqlite0-dev.
>
> If you install sqlite manually from source (e.g. you have it on
> /usr/local/lib/pkgconfig/sqlite.pc), you could probably do something like
> "export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig" (or wherever the file
> is located) before building lxc.
>
>

Sorry, it should be "/usr/lib/x86_64-linux-gnu/pkgconfig/sqlite3.pc" and
"libsqlite3-dev" on Ubuntu 18.04

-- 
Fajar
_______________________________________________
lxc-users mailing list
lxc-users@lists.linuxcontainers.org
http://lists.linuxcontainers.org/listinfo/lxc-users

Reply via email to