Le 02/02/2018 à 02:59, Richard Heck a écrit :
On 02/01/2018 01:59 PM, Scott Kostyshak wrote:
On Tue, Jan 30, 2018 at 02:37:28AM +0000, Scott Kostyshak wrote:

+checking list of textclasses...
Layout file /usr/local/share/lyx-2.3.0rc2/layouts/svglobal3.layout has no
\DeclareXXClass line.
Layout file /usr/local/share/lyx-2.3.0rc2/layouts/ectaart.layout has no
\DeclareXXClass line.
Layout file /usr/local/share/lyx-2.3.0rc2/layouts/bxjsbook.layout has no
\DeclareXXClass line.
Layout file /usr/local/share/lyx-2.3.0rc2/layouts/letter.layout has no
\DeclareXXClass line.
I see these also. We should figure this out, but it's good to know it
doesn't cause any problem.

It very much would cause a problem in certain cases, namely, if you use
--without-latex-config, or if there's some later problem with
chkconfig.ltx. Then textclass.lst is empty.

git bisect suggests 731c9fb4 caused the change.

I put in some debugging code, and the regex simply isn't matching the
lines of the file the way it is supposed to. Ever.

The attached patch fixes it for me. It looks like one of those weird
double-escaping problems. I'm not sure why the switch to binary strings
would cause this, but apparently it does.

I patched lyx-2.3.0rc2 with it, and same behavior.

In the preceding mail, I stated that I did not see anymore the 'no
\DeclareXXClass line' messages when I launched lyx-2.3.0.rc2 again.
In fact, to trigger again the messages, I have to remove ~/.lyx-2.3.0rc2.
If I do this and patch (no recompilation required, right?), I still get the messages.

Same result also with the extended patch you posted next, Richard.


Reply via email to