Le 18 oct. 2016 à 13:06 +0200, Kornel Benko 
<kor...@lyx.org<mailto:kor...@lyx.org>>, a écrit :
Am Dienstag, 18. Oktober 2016 um 10:57:08, schrieb Paola Manzini 
On 18 Oct 2016, at 11:39, Kornel Benko 
<kor...@lyx.org<mailto:kor...@lyx.org><mailto:kor...@lyx.org>> wrote:

Am Dienstag, 18. Oktober 2016 um 10:12:50, schrieb Paola Manzini 
Hi all,

I’ve searched the list and though this is not the first time the problem is 
noted, I haven’t been able to find any solution. The short of it is: it just 
won’t work. So for instance if I type “5+2” then invoke Edit/Math/CAS, I only 
get a lonely = side to the right of the expression, and no result (see 

I am currently running Lyx 2.2.0 on Mac Os Sierra, but I had exactly the same 
problem under Maverick and El Capitan with previous Lyx versions, namely, 
nothing happens.

I have specified the paths correctly (I think) to where the apps are 
(Mathematica, Maxima, Maple - nothing seems to work), and I can see the 
software calling the app (math-extern maxima), or (math-extern mathematica), 
but no result is churned out.

Here is what I have in the "PATH prefix" field under Lyx->Preferences->Paths:

 18/Maple 18.app

Can anyone please help?

Many thanks,


I'd try calling lyx with '-dbg mathed' parameter from a console window.
Alternatively use View->Messages Pane->Settings
Check 'Selected'
Double click on 'mathed - Math editor'
back to 'Output'
calling: maxima
input: 'simpsum:true;tex(5 + 2);'
output: '7'
Buffer.cpp (3449): updateMacro of novýsúbor9.lyx
12:31:27.889: Automatický úklad hotový.

Here it shows:
12:38:28.705: Alt+M Afinding 'finding 'finding 'use whole cell: checking expr: 
'5 + 2'
calling: maxima
input: 'simpsum:true;tex(5 + 2);'
output: '7'


many thanks Kornel for your prompt reply, I’ve tried what you suggested, and 
what I got is no output, namely:

11:55:08.254: (math-extern maxima)finding 'finding 'finding 'use whole cell: 
checking expr: '5 + 2'
calling: maxima
input: 'simpsum:true;tex(5 + 2);’

does this suggest where the problem is?

No, missing: output: '7'

What happens if you call maxima from the console window and input the string 
'(5+2);' followed by <Return>?
Here I get:
(%i1) (5+2);
(%o1) 7



On 18 Oct 2016, at 12:13, Murat Yildizoglu 
<myi...@gmail.com<mailto:myi...@gmail.com>> wrote:

Hi Kornelm
I think that yolu should point İnci'de the .app package, where the unix binary 
I do not have my laptop with me, but it could be the Macos folder in the app 
package (your .app file is in fact a bundle containing sub folders, and one of 
them contains the maxima binary

Prof. Murat Yildizoglu

thanks Murat, but that does not make a difference either, unfortunately, I just 
tried by adding


to the path, but the outcome is the same: just “5+2=“, but no output.

Reply via email to