It don't think that was it, and thanks to Brian too for his help and I am sorry for still not getting it! I think the problem is I don't actually have the agsm style, as I got this error in the .bgl file

I couldn't open style file agsm.bst
---line 148 of file FlexDraft14.aux
: \bibstyle{agsm
:               }

So I tried the style plainnat (with natbib) and also harvard (the .bst I got of the web) and both seemed to work ok, i.e. I get the references alphabetical, but in the text references are still refered to numerically instead of (author, year) which is the citation style I selected. Please can anyone help?


Anders Ekberg wrote:
The same thing happened to me yesterday using BibTeX (through BibDesk). It turned out to simply be that LyX had (for some reason) lost the path to the library. Simply re-including the library solved it.
Hope it's something as simple as that for you too...

Jennifer Brookes
Thu, 07 Feb 2008 09:51:47 -0800

I am having difficulty figuring out how to convert my references to alphabetical (Harvard style) in preparation of an article. I have been using lyx version 1.4.4, with document class article (REVTeX4), citation style natbib (Author-year) and bibliography style agsm. When I compile however, no references appear and there are question marks where I would like the references to be. Before I was using natbib (numerical) and bibliography style apsrev, which worked fine, can anyone tell me the problem?

Many thanks

Reply via email to