I have 2 documents, class koma script book (in french) which I started writing 
back in 2004. Since them, I've been working on them, adding more chapters. They 
don't compile on lyx2.0x as they used to, failing on each and every cross 
reference with a message like:

[18]

LaTeX Warning: Reference `cha:Th=0000E9or=0000EAme-de-Herbrand' on page 19 unde
fined on input line 595.


LaTeX Warning: Reference `cha:Th=0000E9or=0000EAme-de-Herbrand' on page 19 unde
fined on input line 595.

! Missing \endcsname inserted.
<to be read again> 
                   :
l.595 ...ref{cha:Th=0000E9or=0000EAme-de-Herbrand}
                                                  ).
The control sequence marked <to be read again> should
not appear between \csname and \endcsname.

! Extra \endcsname.
<argument> ...E9or=0000EAme-de-Herbrand\endcsname 
                                                  \space 
l.595 ...ref{cha:Th=0000E9or=0000EAme-de-Herbrand}
                                                  ).
I'm ignoring this, since I wasn't doing a \csname.

! Undefined control sequence.
\is@pos@num@ #1\@nil ->\ifx \@nil #1\@nil 
                                          \expandafter \@firstoftwo \else \e...
l.595 ...ref{cha:Th=0000E9or=0000EAme-de-Herbrand}
                                                  ).
The control sequence at the end of the top line
of your error message was never \def'ed. If you have
misspelled it (e.g., `\hobx'), type `I' and the correct
spelling (e.g., `I\hbox'). Otherwise just continue,
and I'll forget about whatever was undefined.

! Missing number, treated as zero.
<to be read again> 
                   \unskip 
l.595 ...ref{cha:Th=0000E9or=0000EAme-de-Herbrand}
                                                  ).
A number should have been here; I inserted `0'.
(If you can't figure out why I needed to see a number,
look up `weird error' in the index to The TeXbook.)

! Missing = inserted for \ifnum.
<to be read again> 
                   \unskip 
l.595 ...ref{cha:Th=0000E9or=0000EAme-de-Herbrand}
                                                  ).
I was expecting to see `<', `=', or `>'. Didn't.

! Missing number, treated as zero.
<to be read again> 
                   \unskip 
l.595 ...ref{cha:Th=0000E9or=0000EAme-de-Herbrand}
                                                  ).
A number should have been here; I inserted `0'.
(If you can't figure out why I needed to see a number,
look up `weird error' in the index to The TeXbook.)

! Extra \endcsname.
\thevpagerefnum ...0000EAme-de-Herbrand\endcsname 
                                                  
l.595 ...ref{cha:Th=0000E9or=0000EAme-de-Herbrand}
                                                  ).
I'm ignoring this, since I wasn't doing a \csname.

! Missing number, treated as zero.
<to be read again> 
                   p
l.595 ...ref{cha:Th=0000E9or=0000EAme-de-Herbrand}
                                                  ).
A number should have been here; I inserted `0'.
(If you can't figure out why I needed to see a number,
look up `weird error' in the index to The TeXbook.)


Overfull \hbox (73.53159pt too wide) in paragraph at lines 590--596
\T1/cmr/m/n/10.95 Jacques Her-brand (cf. [][]  :Th=0000E9or=0000EAme-de-Herbran
d :Th=0000E9or=0000EAme-
 []

Of course, removing the cross references fix the problem... creating a new 
label and cross ref brings it back.
- is this a known problem ?
- any known way to fix this ?
- any idea ?

Reply via email to