On Nov 4, 2007, at 16:54, Mark Grimes wrote:
On Nov 4, 2007, at 13:42, Ryan Schmidt wrote:
On Nov 4, 2007, at 03:31, Mark Grimes wrote:
On Nov 4, 2007, at 1:04 AM, Ryan Schmidt wrote:
On Nov 3, 2007, at 15:38, [EMAIL PROTECTED] wrote:
--- trunk/dports/security/authforce/Portfile 2007-11-03
20:15:07 UTC (rev 30676)
+++ trunk/dports/security/authforce/Portfile 2007-11-03
20:38:14 UTC (rev 30677)
@@ -22,6 +22,9 @@
configure.args --mandir=${prefix}/share/man --infodir=$
{prefix}/share/info
configure.cppflags-append "-L${prefix}/lib"
configure.cflags-append "-no-cpp-precomp -flat_namespace -
undefined suppress -lintl -L${prefix}/lib"
+
+patchfiles patch-http.c
+
FYI: The patchfile should be named "patch-http.c.diff". "port
lint" has some other recommendations for this portfile as well:
$ sudo port lint
Password:
---> Verifying Portfile for authforce
Warning: Line 2 should be a newline (after RCS tag)
Warning: Line 3 should be a newline (after PortSystem)
Warning: Line 16 has trailing whitespace before newline
Warning: Line 24 has trailing whitespace before newline
Warning: Line 32 has trailing whitespace before newline
Warning: Patchfile patch-http.c does not follow the source patch
naming policy "patch-*.diff"
---> 0 errors and 6 warnings found.
$
Aside from the strange "mandated" naming conventions, port lint
is suggesting (as warnings) that diff -p -u is insufficient,
which I find a little disturbing. Is there an alternative set of
diff flags that will make lint happy?
I don't really understand. What is strange about the naming
conventions? And what do you mean "diff -p -u is insufficient"?
What does diff have to do with lint?
You said lint had other suggestions aside from the .diff and I'm
saying this patch is made with diff -p -u so I am assuming all
these suggestions (lint warnings) can be dismissed.
Ah, I see. The port has no maintainer. I thought maybe you were its
maintainer; I didn't look closely enough. In any case, I wanted to
point out to you the patchfile naming situation, and rather than just
state it, I wanted to show you (and others) how you can learn of this
yourself (by using "port lint" before committing). In this case "port
lint" also showed other errors unrelated to the changes you made, and
if you were the maintainer, you might want to take care of those too.
But since the port has no maintainer I went ahead and made the
whitespace changes in r30700.
_______________________________________________
macports-dev mailing list
[email protected]
http://lists.macosforge.org/mailman/listinfo/macports-dev