Hi Peter, Ryan and Chris

Thanks for your replies and advise on how to get macports and gcc9 running on 
my mid 2014 MacBook Pro with macOS 10.14 Mojave installed. That finally worked! 

I then tried to repeat the process for my late 2014 iMac with macOS 10.14 
Mojave installed. To avoid a repetition of all previous mistakes, I wrote a 
procedure based on your suggestions + some on Xcode that I collected from the 
web. (Since there are numerous complaints on Xcode 11.2 and Catalina, I 
downloaded Xcode 10.0.) Below is the procedure, together with the very 
disappointing result that gcc9 again failed to be installed. I have no clou on 
what went wrong and how to fix it. I am very interested in your advise.

And, yes, I have learned from the previous experience, I will better my life 
from now on and perodically update macports.



Procedure to install Xcode, macports and gcc9 one a late 2015 iMac, with macOS 
10.14 Mojave installed

1. Dump the present version of Xcode Xcode 11.1 that came with Mojave):
        -- move Xcode from the Applications to the trash
        -- remove Xcode alias from the dock 
2. Clear the auxiliary files of Xcode:
        rm -rf ~/Library/Developer
        rm -rf ~/Library/Caches/com.apple.dt.Xcode
        -- restart the machine
3. Clear all ports:
        sudo port -fp uninstall installed
4. Check that the port list is empty:
        sudo  port -qv installed
5. Install Xcode 10.0:
-- Open the website 'Migration - MacPorts'
-- move to "2.1.1. Install Xcode on OS 10.9 or later"
-- Click the  text "from the Apple developer website"
After log in with the Apple id a long list of possible downloads appears, "More 
Downloads for Apple Developers". 
-- Click Xcode 10 (14 Sept 2018, far down the list) and double click 'Xcode 
10.xip', which is downloaded (in the upper right corner of the 
'developer.apple.com' window, below a small vertical arrow, a tiny window with 
a progressing blue line appears); takes about 10 min. Xcode_10.xip is now in 
the Downloads folder. Double click expands it to Xcode 10.0 (a small window 
"Archive Utility" on the desktop shows the progress); takes about 6 min.
-- Move Xcode to Applications and put an alias in the dock
        -- Open Xcode once and follow any prompts
6. Install the command line tools:
        xcode-select --install
7. Check that the port list is still empty:
        sudo  port -qv installed
8. Install macports:
Open the website 'trac.macports.org' 
-- click 'Installing Macports in the Guide'
-- click '2.2. Install MacPorts'
-- choose `MacPorts-2.6.2-10.14-Mojave.pkg'.
That package appears in Downloads. Double click and installation proceeds up to 
the message "Installation successful", takes about 1 min.
9. To check that the installation is working, open a new terminal window and 
        port version
        The reply is: "Version 2.6.2": OK!
10. Install gcc9:
        sudo port install gcc9
The reply is in the attached file
        'Failed installation gcc9 - (1) Terminal Saved Output 9-11-2019'
which ends with
--->  Installing libgcc9 @9.2.0_1
Error: Failed to install libgcc9: no destroot found at: 
Error: See 
 for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port gcc9 failed
I do:
        cat main.log
The reply is in the attached file
        'Failure report man.log - (2) Terminal Saved Output 9-11-2019'
which I do not understand.
Still stuck!
11. Check the port list:
        sudo  port -qv installed 
      The reply is:
[/Users/jpg]$ sudo port -qv installed
  bzip2 @1.0.8_0 (active) platform='darwin 18' archs='x86_64' 
  cctools @921_4+llvm80 (active) platform='darwin 18' archs='x86_64' 
  gcc_select @0.1_8 (active) platform='darwin 18' archs='noarch' 
  gettext @ (active) platform='darwin 18' archs='x86_64' 
  gmp @6.1.2_4 (active) platform='darwin 18' archs='x86_64' 
  icu @65.1_0 (active) platform='darwin 18' archs='x86_64' 
  isl @0.21_0 (active) platform='darwin 18' archs='x86_64' 
  ld64 @3_1+ld64_xcode (active) platform='darwin 18' archs='x86_64' 
  ld64-xcode @2_1 (active) platform='darwin 18' archs='x86_64' 
  libcxx @5.0.1_4 (active) platform='darwin 18' archs='noarch' 
  libedit @20191025-3.1_0 (active) platform='darwin 18' archs='x86_64' 
  libffi @3.2.1_0 (active) platform='darwin 18' archs='x86_64' 
  libiconv @1.16_0 (active) platform='darwin 18' archs='x86_64' 
  libxml2 @2.9.9_3 (active) platform='darwin 18' archs='x86_64' 
  llvm-8.0 @8.0.1_0 (active) platform='darwin 18' archs='x86_64' 
  llvm_select @2_0 (active) platform='darwin 18' archs='noarch' 
  ncurses @6.1_0 (active) platform='darwin 18' archs='x86_64' 
  openssl @1.1.1d_0 (active) platform='darwin 18' archs='x86_64' 
  xar @1.6.1_4 (active) platform='darwin 18' archs='x86_64' 
  xz @5.2.4_0 (active) platform='darwin 18' archs='x86_64' 
  zlib @1.2.11_0 (active) platform='darwin 18' archs='x86_64' 
A number of ports are there, but not the essential ones pertaining to gcc9.
No clou on how to proceed!


Failed installation gcc9 - (1) Terminal Saved Output 9-11-2019
Failure report man.log - (2) Terminal Saved Output 9-11-2019

From: Chris Jones <jon...@hep.phy.cam.ac.uk>
Sent: Tuesday, November 5, 2019 2:47 PM
To: Hans Goedbloed; Ryan Schmidt; trainma...@gmail.com
Cc: MacPorts Users
Subject: Re: failure to get gcc9 running

On 05/11/2019 12:28 pm, Hans Goedbloed wrote:
> Hi Peter, Ryan and Chris
> Thanks for your help.
> Reply to Chris Jones:
> -- I am not sure that I removed all ports, how can I find out?
> -- How do I create an empty vanilla MacPorts installation?
> By 'port -u uninstall'?
> To Ryan Schmidt:
> -- (1) Attached is "1a. output of upgrade" and "1b. plist". I can not make 
> anything of it.

You mis-typed the command... Its

 > sudo port -d rev-upgrade


 > sudo port -d rev -upgrade

i.e. rev-upgrade is one word.

I have no idea what the plist file you sent is for ?

> -- (2) I see some perl file dating from 2010 in /opt/local/bin (see attached 
> "2. old perl files").How to update "libpreludedb's +perl variant"?

 > sudo port sync
 > sudo port upgrade outdated

> -- (3) Attached is the list of the "3. old local portfiles". In fact, they 
> date from 2014, but they also have a copy labeled ".default". Should I just 
> delete all of them?

That is not what Ryan asked for. He asked if you had configured your
local installation to use a custom local Portfiles. i.e. have you
*changed* /opt/local/etc/macports/sources.conf ??

( At this point though, given all the problems you have its going to be
very hard I would say for anyway to understand what you have, and have
not done to your system, as part of the upgrade process, so probably the
simplest approach is to wipe out the macports installation and start
afresh. Just my view, others might disagree. )


Attachment: Failed installation gcc9 - (1) Terminal Saved Output 9-11-2019
Description: Failed installation gcc9 - (1) Terminal Saved Output 9-11-2019

Attachment: Failure report main.log - (2) Terminal Saved Output 9-11-2019
Description: Failure report main.log - (2) Terminal Saved Output 9-11-2019

Reply via email to