As far as the package structure is concerned, Benson proposed something similar to the the following:
o.a.m.matrix -> o.a.m.math o.a.m.jet -> o.a.m.math.jet Things currently under o.a.m.matrix would retain their existing names, with s/matrix/math, for example: o.a.m.math.bitvector o.a.m.math.buffer o.a.m.math.function o.a.m.math.list o.a.m.math.map o.a.m.math.matrix The maven submodule would be changed from mahout-matrix to mahout-math As far as committing cleanup changes -- it is whatever is in the patch to MAHOUT-222, which I have not reviewed Once 222 is committed I'll submit the reorg patch and more cleanup can proceed from there. I'm certainly open to alternatives as well, just trying to jump in where I can help. Drew On Mon, Dec 14, 2009 at 11:23 AM, Jake Mannix <[email protected]> wrote: > So we're committing cleanup changes first, and then doing reorg, right? > > I'm for o.a.m.math, but we need to decide on where stuff goes in subpackages > below that, and then where to put stuff as far as maven submodules too. > > -jake > > On Mon, Dec 14, 2009 at 8:11 AM, Drew Farris <[email protected]> wrote: > >> No worries Sean -- it is really great to have your attention on the issue. >> >> On Mon, Dec 14, 2009 at 11:00 AM, Sean Owen <[email protected]> wrote: >> > No it's my bad, I missed one word while reading that message too fast >> > and misunderstood. Sorry for over-eagerly jumping in, I'll stay out of >> > this. >> >
