But much of the math stuff is built out of the collections stuff (what is a vector but a collection of doubles and ints...)
On Mon, Dec 14, 2009 at 9:42 AM, Benson Margulies <[email protected]>wrote: > Would heads explode if I suggested two new components: mahout-math and > mahout-collections, the second depending on the first? > > On Mon, Dec 14, 2009 at 11:59 AM, Jake Mannix <[email protected]> > wrote: > > As far as I'm concerned, we can probably do this in steps, as long as we > > stabilize before 0.3, so no pushing down for now. > > > > -jake > > > > On Mon, Dec 14, 2009 at 8:53 AM, Drew Farris <[email protected]> > wrote: > > > >> That's a good question. I was not going to push them down, but if > >> you/others believethat they should be pushed down at this point I'd be > >> happy to do so. > >> > >> On Mon, Dec 14, 2009 at 11:41 AM, Jake Mannix <[email protected]> > >> wrote: > >> > This all makes sense, I'm just wondering about the fact that now in > the > >> > top-level > >> > in o.a.m.math, we have Vector, Matrix, SparseVector, etc. from the > >> original > >> > Mahout > >> > linear algebra stuff. > >> > > >> > Should these not get pushed down into the math.matrix subdirectory > >> (except > >> > for > >> > the functions which go down into math.function)? > >> > > >> > I can see *not* pushing them down, because it completely intermingles > our > >> > old > >> > code with the Colt stuff, but at some point, they're going to be > >> > intermingled, right? > >> > > >> > -jake > >> > > >> > On Mon, Dec 14, 2009 at 8:32 AM, Drew Farris <[email protected]> > >> wrote: > >> > > >> >> As far as the package structure is concerned, Benson proposed > >> >> something similar to the the following: > >> >> > >> >> o.a.m.matrix -> o.a.m.math > >> >> o.a.m.jet -> o.a.m.math.jet > >> >> > >> >> Things currently under o.a.m.matrix would retain their existing > names, > >> >> with s/matrix/math, for example: > >> >> > >> >> o.a.m.math.bitvector > >> >> o.a.m.math.buffer > >> >> o.a.m.math.function > >> >> o.a.m.math.list > >> >> o.a.m.math.map > >> >> o.a.m.math.matrix > >> >> > >> >> The maven submodule would be changed from mahout-matrix to > mahout-math > >> >> > >> >> As far as committing cleanup changes -- it is whatever is in the > patch > >> >> to MAHOUT-222, which I have not reviewed Once 222 is committed I'll > >> >> submit the reorg patch and more cleanup can proceed from there. I'm > >> >> certainly open to alternatives as well, just trying to jump in where > I > >> >> can help. > >> >> > >> >> Drew > >> >> > >> >> On Mon, Dec 14, 2009 at 11:23 AM, Jake Mannix <[email protected] > > > >> >> wrote: > >> >> > So we're committing cleanup changes first, and then doing reorg, > >> right? > >> >> > > >> >> > I'm for o.a.m.math, but we need to decide on where stuff goes in > >> >> subpackages > >> >> > below that, and then where to put stuff as far as maven submodules > >> too. > >> >> > > >> >> > -jake > >> >> > > >> >> > On Mon, Dec 14, 2009 at 8:11 AM, Drew Farris < > [email protected]> > >> >> wrote: > >> >> > > >> >> >> No worries Sean -- it is really great to have your attention on > the > >> >> issue. > >> >> >> > >> >> >> On Mon, Dec 14, 2009 at 11:00 AM, Sean Owen <[email protected]> > >> wrote: > >> >> >> > No it's my bad, I missed one word while reading that message too > >> fast > >> >> >> > and misunderstood. Sorry for over-eagerly jumping in, I'll stay > out > >> of > >> >> >> > this. > >> >> >> > >> >> > > >> >> > >> > > >> > > >
