Thanks a lot for your input! You wrote:
> Lars Bjørndal writes: > > > https://lamasti.net/filer/shutdown.log.gz > > You've got some kind of logging problem with writing to the persistent > storage for the log, whatever that is (defaults to several files in > $var/dir/logs, but can be configured very flexibly using the stdlib > logging module). I've installed mailman3 following the guide at https://docs.mailman3.org/en/latest/install/virtualenv.html. So Mailma's log files is in /opt/mailman3/mm/var/log. But the log I've provided, is, as you say, from systemd/journalctl. > A bunch of Mailman processes are raising exceptions > when trying to log that they're shutting down. This could result in a > deadlock, which is why systemd terminates the processes with SIGABRT. > > There's also a message about reentrancy (I think only one per process, > but Mailman 3 spawns lots of processes). It might be a bug in logging > (not Mailman code) but I think that's some exception handler that's > trying to log the logging exception. If so, it's not the root problem > and should not recur if you fix the basic problem. > > 1. What, if anything, is in Mailman's own logs? This appears to be > systemd's log from journalctl. In /opt/mailman3/mm/var/logs/error.log I have: ``` [2026-07-20 08:57:39 +0200] [2594] [INFO] Handling signal: int [2026-07-20 08:57:41 +0200] [2594] [ERROR] Worker (pid:2596) was sent code 131! [2026-07-20 08:57:42 +0200] [2594] [INFO] Shutting down: Master [2026-07-20 09:02:00 +0200] [2510] [INFO] Starting gunicorn 23.0.0 [2026-07-20 09:02:00 +0200] [2510] [INFO] Listening at: http://127.0.0.1:8000 (2510) [2026-07-20 09:02:00 +0200] [2510] [INFO] Using worker: sync [2026-07-20 09:02:00 +0200] [2538] [INFO] Booting worker with pid: 2538 ``` > 2. Do you have any settings for logging in mailman.cfg? No, nothing. > 3. If your logging handler is a file-based handler, maybe the log > partition is full. Both /opt and /var is on the same file system with lot of space. > 4. Maybe there is some security restriction (selinux?) on the logging > channel, whatever it is. Or a permissions restriction on the file > system so Mailman can't write. I don't think so, because Mailman writes to it's logs in /opt/mailman3/mm/var/log. I don't use selinux. > I also noticed that PostgreSQL gets shut down, but there's no log that > it gets restarted. I think Mailman should then shutdown with an error > that it can't talk to the database, but maybe it retries a few times. >From the log I can see that PostgeSQL is started before mailman tries to start. Lars _______________________________________________ Mailman-users mailing list -- [email protected] To unsubscribe send an email to [email protected] https://lists.mailman3.org/mailman3/lists/mailman-users.mailman3.org/ Archived at: https://lists.mailman3.org/archives/list/[email protected]/message/ELIGYQMQX2NH33T43MJQVS7MJZDEU22B/ This message sent to [email protected]
