[ 
https://issues.apache.org/jira/browse/MAPREDUCE-4260?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13284629#comment-13284629
 ] 

Ivan Mitic commented on MAPREDUCE-4260:
---------------------------------------

Thanks Bikas! Change looks good.

A few questions/suggestions:
1. Is the plan to have this be part of winutils? (I assume yes, just double 
checking)
2. Should we also update/rename/reuse ProcessTree#isSetsidSupported to account 
for the fact that we now support "process groups" on Windows?
3. Maybe rename JVM_PID accordingly, as it implies that it is a process ID 
while it is not anymore? Depending on #2, this might not be needed.

Per your comment that you want to clean up your change, I’ll take another look 
once it is ready.
                
> Investigate use of JobObject to spawn tasks on Windows
> ------------------------------------------------------
>
>                 Key: MAPREDUCE-4260
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-4260
>             Project: Hadoop Map/Reduce
>          Issue Type: Improvement
>    Affects Versions: 1.0.0
>            Reporter: Bikas Saha
>            Assignee: Bikas Saha
>         Attachments: MAPREDUCE-4260.patch, test.cpp
>
>
> Currently, the Windows version spawns the task as a normal cmd shell from 
> which other downstream exe's are spawned. However, this is not bullet proof 
> because if an intermediate process exits before its child exits, then the 
> parent child process tree relationship cannot be constructed. Windows has a 
> concept of JobObject that is similar to the setsid behavior used in Linux. 
> The initial spawned task could be launched within its JobObject. Thereafter, 
> process termination, memory management etc could be operated on the JobObject.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


Reply via email to