After looking at Aaron's site I see a couple of things:
1. I would go with FWTools if I could but I am concerned about my webhost having an out-dated version of libgd. (2.0.28)
I am wondering if I can combine the installation of FWTools with a local libgd?
I see that FWTools has a help mailing list, so that is probably the appropriate place for me to ask this.
2. I see several things in the instructions on Aaron's site that are different than what I did, so I can try it his way and see if that makes a difference.
In particular, the configure command is different: I used
./configure --prefix=$HOME/local --without-python
make install
while Aaron used
./configure --prefix=/home/racicot/usr/local --with-static-proj4=/home/racicot/usr/local/lib --with-local=/home/racicot/usr/local
make ogr-all
make install

I'll let you know how it turns out.

Thanks, Tara

Aaron Racicot wrote:
Coming to this conversation late, so I am not sure what you have tried.  I
have had success on a shared host two ways:

1) Install FWTools as it contains Mapserver and GDAL and is self contained.

2) I have played with static library paths via RPATH when compiling from
source with success in the past.  I even documented an install on DreamHost
(pretty much the cheapest of the cheap) that worked.

Hope these help...


 Aaron Racicot - GIS Programmer   
 360.221.2441 - [EMAIL PROTECTED]          
 z - p u l l e y                        
 pobox 1614
 langley wa 98260                       

-----Original Message-----
From: UMN MapServer Users List [mailto:MAPSERVER-USERS@LISTS.UMN.EDU] On
Behalf Of Tara Athan
Sent: Tuesday, August 28, 2007 10:09 PM
Subject: [UMN_MAPSERVER-USERS] hosted website installation

Additional information that may or may not be relevant:  my ISP responded as

Dear Customer,
There is no server side limitation to paths.  You may specify custom paths
to any library that you have need of using.  The only limitation would be on
the library itself (whether it could be accessed from an alternate location)
and the program that needs to access the library.

So basically they are saying it must be either gdal's fault or MapServer's
fault that mapserver cannot access the gdal library from an alternate

Anyone care to weigh in on this?

I guess I am giving up on the installation of Mapserver on the hosted 
website and will have to get some help from a GIS hosting service (or 
set up my own web server).  But it seems like this should have been doable.

Anyway, thanks for the help- I certainly learned a lot in the attempt...


Tara Athan wrote:
I tried this- no change.
I tried getting support from my ISP, but they are unwilling to help.
(mapserver?  we don't know anything about that- ask the support forum)

Has anyone else had success or problems with bringing up MapServer on 
a hosted website?


Gregor Mosheh wrote:
Tara Athan wrote:
I found in /home/alttwois/local/lib
On running ./mapserver -v, I get the same error message as before
/home/alttwois/public_html/cgi-bin/mapserv.real: error while loading 
shared libraries: cannot open shared object file: No 
such file or directory
Well that's bizarre. How about this?

/home/alttwois/public_html/cgi-bin/mapserv.real -v

That's all one line. That sets the linker path on the command line, 
then runs the command.



My e-mail delivery has been unreliable lately, so I am asking for
return receipts from all my email messages.
OK'ing the return receipt lets me know that my message was delivered.
Thank you.

Tara Athan
Principal, Alternatives to Invasive Species
PO Box 415
Redwood Valley, CA 95470

Reply via email to