On Tue, 13 Mar 2018, at 07:09, dhananjay patade wrote:
> I am trying to deploy an application. If I run puppet agent manually by 
> logging in to that agent machine, everything works fine, But when I run 
> "mco puppet runonce -I hostname" from my puppet server deployment fails. 
> This happens because my application reads "user.name" property from system 
> properties. 
> When I manually run puppet agent, agent facts are correctly set.
>  id => WORKGROUP\ranger_win7
>       identity => {"privileged"=>"true", "user"=>"WORKGROUP\\ranger_win7"}
> But when I run agent using mcollective, above facts changes to following.
>       identity => {"privileged"=>"true", "user"=>"WORKGROUP\\RANGER_WIN7$"}
> so when application reads user.name , its getting user name as 
> "RANGER_WIN7$" which is wrong.
> Any one has clue why this is happening?

The one with the $ is a managed service account, so its basically a different 
account than you'd have when logging in?

I think, I don't know much about windows I am afraid

R.I.Pienaar / www.devco.net / @ripienaar


You received this message because you are subscribed to the Google Groups 
"mcollective-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to mcollective-users+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to