On 08/05/2017 11:10 PM, Paul de Weerd wrote:
> Hi Ulf,
> On Fri, Aug 04, 2017 at 11:26:12PM +0200, Ulf Brosziewski wrote:
> | Hi Paul,
> | 
> | thanks for your help.  Does tapping work when you use
> | the synaptics driver?
> Nope, it doesn't.

which probably means there is either something happening that
our hardware driver doesn't cover, or there is a hardware/firmware
bug.  Anyhow, it's strange because the drivers only need very
basic data to identify a tap: the start of a contact, its
end, and the duration.  Have you checked - with the synaptics
driver - whether a higher tap timeout helps?  If not, would you
mind to make a short test?  Could you increase the tap timeout
to a very high value, say, two seconds, and test whether a tap
works (with a slight delay)?  For the wsmouse-internal driver,
the following command will set a two-second timeout:
    # wsconsctl mouse.tp.param=137:2000
Of course you could not work reasonably with such a timeout,
you might want to check then whether something between 200
350 milliseconds would do.  The default is 180.

> | In the test setup with ws and the internal driver there
> | are some restrictions on tapping:
> |     1) It is suppressed when the position is an edge area
> |     (presumably the software button area at the bottom
> |     edge in this case).
> Normally, I'm tapping in the center of the touchpad.  But I've tried
> various locations, all don't work.
> |     2) The finger must not move by more than a certain
> |     distance, otherwise, the contact doesn't count as
> |     "tap".
> I've tried quite a few times, but no luck.  I'm pretty sure at least
> some of those attempts were in basically the same spot :)
> |     3) It is suppressed when hardware buttons are being
> |     pressed.
> I don't even try this :)
> | Just to be sure, can you exclude that 1), 2), or 3) is
> | the reason for the problem?  And neither one-, two-, nor
> | three-finger taps work?
> I can: no tapping works, with any number of fingers.  I should,
> however, clarify one thing:
> | > This doesn't work on my touchpad.  Also, I can't click-and-drag (never
> | > worked, in any combination I while playing with the driver settings).
> This 'click-and-drag' behaviour does work if I click, keep the button
> depressed and then move that same finger around.  [...]

Does this also work if you put a second finger on the touchpad (which
does nothing)?

> [...]  So I can't click
> with one finger and drag with another.
> Cheers,
> Paul

Reply via email to