On Mon, Aug 07, 2017 at 01:13:22AM +0200, Ulf Brosziewski wrote:
| On 08/05/2017 11:10 PM, Paul de Weerd wrote:
| > Hi Ulf,
| > 
| > On Fri, Aug 04, 2017 at 11:26:12PM +0200, Ulf Brosziewski wrote:
| > | Hi Paul,
| > | 
| > | thanks for your help.  Does tapping work when you use
| > | the synaptics driver?
| > 
| > Nope, it doesn't.
| > 
| which probably means there is either something happening that
| our hardware driver doesn't cover, or there is a hardware/firmware
| bug.  Anyhow, it's strange because the drivers only need very
| basic data to identify a tap: the start of a contact, its
| end, and the duration.  Have you checked - with the synaptics
| driver - whether a higher tap timeout helps?  If not, would you
| mind to make a short test?  Could you increase the tap timeout
| to a very high value, say, two seconds, and test whether a tap
| works (with a slight delay)?  For the wsmouse-internal driver,
| the following command will set a two-second timeout:
|     # wsconsctl mouse.tp.param=137:2000
| Of course you could not work reasonably with such a timeout,
| you might want to check then whether something between 200
| 350 milliseconds would do.  The default is 180.

I tried that:

[weerd@drop] $ doas wsconsctl mouse.tp.param=137:2000
mouse.tp.param -> 137:999

But I still can't tap.

| > | > This doesn't work on my touchpad.  Also, I can't click-and-drag (never
| > | > worked, in any combination I while playing with the driver settings).
| > 
| > This 'click-and-drag' behaviour does work if I click, keep the button
| > depressed and then move that same finger around.  [...]
| Does this also work if you put a second finger on the touchpad (which
| does nothing)?

No, but you helped me find something useful / interesting:

1. click button (keep depressed)
2. second finger doesn't do anything


1. touch 'second finger' first
2. click button (keep depressed); now the 2nd finger can drag (1st
   finger doesn't work for dragging now)

This in addition to

1. click button (keep depressed)
2. move 1st finger around on small clickable area to drag

So, with this new approach, I have more surface area to drag around
and I can release my second finger to scroll beyond the end of the
touchpad.  Never knew this was an option, I feel like an idiot now :)




Reply via email to