On Fri, Apr 13, 2018, at 9:31 AM, Stuart Henderson wrote:
> Can you show your whole hostname.pppoe0 file? (mask your password of
> course).  On Zen I'm using the following
> mtu 1500
> inet pppoedev em1 authproto chap 
> authname "XXX@zen" authkey "XXX" up
> inet6 -autoconfprivacy
> inet6 autoconf
> !/sbin/route add default -ifp pppoe0
> !/sbin/route add -inet6 default -ifp pppoe0 fe80::%pppoe0 -priority 8
> and hostname.em1 has
> mtu 1508
> up
> In my case, I'm using dhcpcd from packages to get addresses for my internal
> networks, Zen don't statically route my v6 block unless I request it via
> DHCPv6-PD, but you won't need that with A&A, you can just configure them
> statically on the inside interfaces.

Of course, here is my /etc/hostname.pppoe0:
inet NONE mtu 1500 pppoedev em1 authproto chap authname 
foo authkey bar up
inet6 eui64
!/sbin/route add default -ifp pppoe0
!/sbin/route add -inet6 default -ifp pppoe0 fe80::%pppoe0

and my /etc/hostname.em1 is:
inet NONE mtu 1508

Which I think was just me attempting to make it so that I could talk to my 
modem previously... Anyway the connection comes up and I can do 1500 byte 
packets over it so all good in that respect.

My config is basically lifted almost verbatim from the first example on the 
pppoe(4) man page, with the 1500 mtu modifications from the example lower 
down... So either there is something really weird with my particular setup 
which means that this example is no longer suitable, or the example does not 
work like expected on 6.3.

As previously mentioned I also tried it with 'eui64' changed to 'autoconf',  
but it didn't seem that SLAAC was seeing RAs from the remote end - maybe that's 
not set up on A&A, or something else is configured wrong? I did try opening up 
my pf ruleset a bit but it made no difference. However I used an older version 
of the manpage example on my previous OpenBSD 5.8 router (i.e. no SLAAC or 
other thing doing any v6 configuration) and it worked fine, so something is 
seemingly altering the v6 route table in between the pppoe0 if being brought 
up, and it actually establishing a session...


Reply via email to